Are there any non-standard/undocumented things to try (setting up BBS)
#1
I have my Paragon BBS backup from the early 90's and for years I've tried to get it online with different setups, I believe I've used 100 hours with no success. Finally I bought the WiModem232 even though it was a bit expensive (+150usd with all the taxes and stuff) but I just still can't get it working. I am pretty sure I have tried anything and everything but still no. Best I've achieved is a few lines from the BBS and then disconnect. More on that in EAB, https://tinyurl.com/vtyfh4uf

Anyway. Back in the day I had the cheapest 2400bps modem, a self made cable (naturally I don't know the connections any more, but something very basic it had to be) and an init string of "ATH0 S0=1 X1 V0 S7=9 S9=25 S10=14 M0 L &D2". Now that I just can't get it to work (more specific description in the link above) I was wondering if there is anything rare/undocumented/nonstandard solution I could try to get things going. The Paragon BBS seems to be quite rare so nobody knows anything about it so maybe it has some special functionality and/or maybe the Asta 2400BPS modem had something strange in it which made the BBS work.

If none can be found, then I think there is nothing more to try than manually emulating DCD DTR etc signals of a modem with a null-cable between two Amigas and hopefully finding that way what the BBS wants.

And one thing. Should there ever be signal on the Ring Indicator pin? I am not sure it it's important in my case (default setup be'ing ATS0=1 but S0=0 with ATA also possible) but that pin never anything else then 0.00v.
Reply
#2
There are a LOT of people running BBS's using the WiModem and WiModem232 modem emulators.  You just need to use the proper init string, and proper cable.  The biggest mistake that I see is that people try to use a NULL modem cable instead of a modem cable!  A NULL modem cable is designed to interface two computers together, not a computer and a serial device.

You should have contacted me in the first 10 minutes that you had a problem, not 100 hours into it!  Smile

Your init string break down as:

H0 - hang up the modem (not needed as it should already be hung up)
S0=1 - answer incoming call on the first ring
X1 - extended connect message mode (this requires the BBS to know the exact connect message for setting the baud rate)
V0 - result code (numeric)
S7 = 9 - wait time for carrier after dialing (this would never be used with a BBS since it is not calling out)
S9 = 25 - carrier detect response time (amount of time to wait in 1/10th of a second - so 25*0.10 second before proceeding)
S10 = 14 - delay between lost carrier signal and hang up (does nothing with WiModem232)
M0 - speaker off (does nothing with WiModem232)
L - ???  You are missing the character after the L!  This is a volume level (not used with WiModem232) but this should generate an error.  I need to look at that.
&D2 - this changes how the hang up works, which is fully supported by the WiModem232 (but modem specific and not necessary).

There is nothing abnormal about your init string, but really it just needs to be ATS0=1 and that's it.  Everything else is not required.

The RI pin is fully controlled, so on an incoming call the RI pin should toggle high/low.

You don't actually state in this message what problem you are actually having!  I will read/respond to your message on EAB.
Reply
#3
I looked at the BBS and used your LHA to set it up.  Right in the middle of testing it my A1200 died!  Ugh!  So, I need to figure out what happened to it.

In the mean time, there are some things you need to look at:

First, the WiModem232 must be set (permanently) to the baud rate you intend to use.  If your max baud rate for your BBS is 19200, then you need to use a terminal program and change the default baud rate (300) to 19200 using AT*B19200 and then AT&W to store that.

Second, you must use the "J" feature in the config to LOCK the baud rate at whatever baud rate you have set the WiModem232 to (19200 in the above example).  The MAX baud rate setting should also be set to the same.

Use this for your init string: ATS0=1

The documentation is great at explaining the options, but it does not actually tell you how to RUN the BBS!  Do you run the ParCon program and that invokes the BBS?  There is no info on how the BBS actually knows there is an incoming call.  If it looks for an extended code (ie CONNECT 9600) instead of just CONNECT, or checking the DCD line then you would need to add the X1V0 part of the init string.  There is no info on this, so it's hard to know what is required and now that my A1200 won't boot, I can't test this any further today.  Maybe you are not locking the WiModem232 at whatever baud rate you want to use, and matching that in the config?

One thing that I did learn today is that I should change at least the LED (probably the OLED screen as well) when an incoming connection is being attempted.  This would help diagnose if a connection attempt is even being made.
Reply
#4
OK, I fixed the A1200 and did some more experimenting. I can connect just fine every time, but the BBS is deliberately hanging up after it finds there is a connection.

The biggest issue in your init string is that ATH0 is not a stackable command. This means that if you put any text after the ATH0 (like ATH0S0=1) that will return an error. I thought this command was stackable, so I will check that. If you just place the H0 at the end of the string instead of the beginning, then it works fine.

So, at this point I need to figure out what the BBS is looking for to know that there is a valid connection.

For testing of the WiModem232 I set the baud rate to 9600 baud (and stored that baud). I launched the ParCon then I launch the BBS using:

Paragon 1 B9600 L9600

This sets and locks the baud rate at 9600. I didn't try changing this with the CONFIG program, but that probably works. This override works as well.

At this point I am guessing that the numeric code that the BBS is expecting is different from the extended set. I will have to look into that. But at least it connects on a call, and the BBS recognizes the connection - it just doesn't like it (yet). Smile
Reply
#5
I noticed you had a readme file included in the archive:

Currently my WiModem232 (and Paragon) is set up to use 1200bps
and the other settings of my WiModem (AT&V) are as follows:

B0 C0 E1 L2 M0 N0 Q0 V1 X1 S0:1 S1:0 S2:43 S3:13 S4:10 S5:8 S6:2
S7:60 S8:2 S9:6 S10:15 S11:90 S12:50 S25:0 S30:30 S37:6 *BL512
*C0 *D0 *R0 *T0 &C1 &D2 &G0 &K0 &Q0 &S0

You definitely want to get rid of the &D2 and make that &D0.  Your init string changes S0, X, and V so you don't need those values stored (unless you want to eliminate those from the init string).

I didn't realize that the problem you are experiencing is really not WiModem232 related.  It seems that you can't make this BBS software work with anything (as stated in your readme).  However, since all other BBS programs (for many different computer systems, including the Amiga - like AmiExpress) work fine with the WiModem232 I am sure that this is some simple setup issue, or maybe the BBS software is looking for an exact (strict) text formatting?  I will see what I can figure out.
Reply
#6
Well, it works (new firmware update required)!  Still lots of changes to be made though before pushing the new update.

   

   
Reply
#7
Interesting. And _literally_everything_ you wrote above (about ATH01, locking baud rates, &D2, *everything*) I know and I have tried. I've used over 10 hours today alone with it.


>> You should have contacted me in the first 10 minutes that you had a problem, not 100 hours into it!

Well the first 70 hours has been with some other setups, bought yours when nothing worked.

The H0 in the init string is from the manual and I used it back in the day, haven't used it now. And actually the whole init string was just some default, I've tried everything from a simple ATS0=1 to a really long with all possible options. And I am very well aware of there not be'ing sounds, and I've left those usually away from my tests.

And I do know how to set the baud rate on the WiModem as well as setting up the max and locked rates of Paragon. If I go to the Paragon terminal (F2 while waiting a call) and type in ATI I get a clear reply. And I do know about AT&W


>> At this point I am guessing that the numeric code that the BBS is expecting is different from the extended set.

I've sent 'modem result codes' from another Amiga and Paragon understands them correctly, for example 5 = CONNECT 1200


>> You definitely want to get rid of the &D2 and make that &D0

Tried that with various other combinations.


>> The biggest mistake that I see is that people try to use a NULL modem cable instead of a modem cable!  A NULL modem cable is designed to interface two computers together, not a computer and a serial device.

I'm aware of that. I have various cables and they have been tested and at least ½ of my testing has been done with the WiModem directly connected to the computer.


>> The RI pin is fully controlled, so on an incoming call the RI pin should toggle high/low.

I am pretty sure nothing happens on my device. Made a extension cord from which I can measure the pins just next to the Modem, and at least nothing can be seen on a normal multimeter. Other pins seem to work like they should.


>> Well, it works!

Nice! Good for you! Any chance you could share your init string, the few settings in the Paragon Config utility and specially the AT&V printout?

I also made a factory reset a few hours ago and that too was hilarious. The baud rate should reset to 300 but it still worked at 1200 (I didn't touch my terminal and the bottom line showed 1200 bps) but ATI was telling me it's on 300bps.

I'm tired. Too tired to be even angry any more.
Reply
#8
There should be nothing to be "angry" about. You found some bugs, I fixed them, and now Paragon works. I am still working on the new update.  It fixes the bugs that were causing the issue you have, and now adds a bunch of new features.  I am doing some testing to a make sure test I didn’t break anything in the process. I actively (daily) support all of my products, so you can check pretty much throughout the day for responses to posts here.

I used the following init string (with the new v3.50 firmware update) for Paragon:

ATH0X1V0

You don't need (or want) AT&D2. One of the things I fixed was the stacking of H0, which was generating an error because it did require to be an isolated (non-sequential) command. Now you will be able to put H0 anywhere in a string of commands.

Again, you will need the new firmware in order for you to use Paragon, and I am still testing it. Don't waste anymore of your time trying to get Paragon to work with the firmware you have currently - it won't work until you have the new update.

A factory reset does NOT change the working baud rate, just the stored baud rate.  That is how the Hayes standard defines how the AT&F command works! If you reboot the modem, it will then switch to the baud rate set by AT&F (300 baud). This is how my USR Courier, Supra 2400, and other real modems I have here all work... but that is what is defined by the Hayes standard, so that is not surprising.
Reply
#9
>> There should be nothing to be "angry" about.

Guess not, but when I bang my head against a wall for hours and days, I usually become a little (?) p'd off. Happens with everything, not just in this case.

>> Don't waste anymore of your time trying to get Paragon to work with the firmware you have currently - it won't work until you have the new update.

Well *this* is just what I wanted to hear. Because I believe I have tried everything (including at least 15 different versions of string, different modem settings, cables, 500/600/1200 Amigas, all the combinations possible from Paragon config) and nothing has helped so I really have started to think there must be something wrong which isn't in my hands.

So now I just wait and that is perfectly fine now that I know there is nothing else I can do. It would be fine even if I was told that it will never be fixed, just as long as I know that it's a case of square block and a round hole that just will not work no matter what *I* do and I can stop trying.
Reply
#10
It will be fixed (it already is), but I am trying to track down another bug in the storage handling code (used mostly for the C64), so that is what I am looking at currently. If it's going to be a long time to fix then I can release an interim version that at least fixes your issue.

It is interesting that all of the other devices you have tried besides the WiModem232 also do not work.
Reply




Users browsing this thread: 4 Guest(s)