BBSes with cursor navigation menus not working
My WiModem232 arrived and works great, but we are having an issue. BBSes that use ANSI cursor based navigation menus are not working as intended. For instance, the sysop at Onyx BBS has a bot checker that requires you to use the left or right cursor keys to "rotate" through numbers 0 - 9 to verify you are human but we are unable to navigate the numbers.

On a diffrrent BBS we are unable to use the cursor key to navigate their message section, or ANSI art gallery it just puts you back a menu or exits you out entirely.

It happens no matter what terminal software we use, what baud rate we set, flow control on or off, nor which rs-232 cable we use. I can say from experience this issue doesn't exist with the Zimodem based wifi modem we were using, so I'm at a loss on what's going on.

Everything on the WiModmem232 is set to default. The computer being used with the WiModem232 is a Intel DX4 100MHz 486 DOS PC.
What terminal software? Are you using a RAW or TELNET connection? What is the URL for the BBS? Typically, issues like these are due to not having the correct protocol (RAW vs. TELNET). The WiModem232 passes whatever it receives from the terminal program.
If you are referring to ONYX BBS - I was able to connect to it and spin the dial. I can't tell what I am doing because the Amiga doesn't have a terminal program that supports ANSI/CP347 terminal emulation, but the dial rotates in crummy ANSI. I am guessing you are suppose to spin it and then hit ENTER on each number you want to select?
(11-13-2022, 11:26 PM)admin Wrote: If you are referring to ONYX BBS - I was able to connect to it and spin the dial.  I can't tell what I am doing because the Amiga doesn't have a terminal program that supports ANSI/CP347 terminal emulation, but the dial rotates in crummy ANSI.  I am guessing you are suppose to spin it and then hit ENTER on each number you want to select?

Hi Jim,

Terminals tried: Telemate, Telix, BananaCom, Qmodem Pro, ProComm Plus, etc. Not sure what you mean by RAW or Telnet connection. I simply ATDT into the BBSes, settings of the WiModem232 are set at default, terminals are in a pure MS-DOS environment.

As for Onyx BBS, yes you use the left or right cursor keys to scan through the numbers and press escape instead of enter.  Shy 

The issue is occuring with any BBS that needs cursor input for navigation or menu navigation including DOOR games, all share this behavior that no other wifi modem solution seems to exibit on this DOS machine.

It's probably something simple but for now it's frustrating.  Tongue
You need to know if a BBS is using a Telnet or RAW connection before you call it. If it is using a Telnet connection, you have to set the WiModem232 to use Telnet mode (AT*T1). Telnet is a protocol that some portals use.

I am in contact with the SYSOP at ONYX about this and I am working on it. I can see the same problem you describe on my PC using internet direct (no WiModem232) using ZOC8, or SyncroNet.. but NetRunner works correctly. So, this must be either a Telnet issue or something related to ANSI codes. Only the Telnet would make a difference, as data is data and the WiModem232 only passes data. Only Telnet mode is different.

I have not looked at ANY of the other WiFi modems. I have been making the WiModem series since 2015, before anyone else was doing this.
Thanks for all the assistance in this Jim. It doesn't matter if it's RAW or Telnet mode set, the issue still exists.

However, I do have some more information though... the issue seems to be with BBSes that run Mystic, as none of the cursor based menu navigation (lightbar menus, navigation) seem to be working if a sysop has it enabled. It's as if the ESC key is being pressed when the cursor keys are pressed. The author of the Mystic software is still developing for it so maybe they have an answer for what is going on.

Synchronet based BBSes do not seem to have this issue when they have lightbar menus or navigation.

The issue isn't just in DOS, I fired up Windows 3.11 and the same thing happens when connecting to Mystic based BBSes. So, I just wonder of it's an incompatibility with WiModem232 and Mystic.
The WiModem232 passes whatever data is sent to it. I am not sure what type of "incompatibility" there could be other than maybe some Telnet command that I am not supporting.

As I said previously, I see this exact same problem on my PC when using ZOC8, RealTerm, and other terminal programs, all using an Ethernet connection with no WiModem232 being used. So, this is definitely not a WiModem232 issue. The ONLY terminal program where I see this work is NetRunner on my PC.

I found a laptop with Windows ME on it that has a RS232 port. Can you point me to some link(s) for a terminal program that you know should work (shows the lock correctly)?

The SYSOP for ONYX BBS turned off enabling the cursor. You should try it now to see if it works or not.

In the mean time, I would like to know the difference of why it works on one terminal and not another, especially with no WiModem232 involved at all. I am guessing it is Telnet code escaping that is being used. I only support the basic set of Telnet commands because Telnet is very rarely used anymore and there are more than 1,000 Telnet functions, with probably 50 or so main ones that would be necessary for some things to work. It's just really rare this is ever a concern. The terminals that I have tried on my PC I know don't support Telnet escaping, so that seems to be the only thing in common that I can find as to why this would not work on different terminals.
I just looked at the "Zimodem" history info, and if you are using ATDT to "dial" with it then it is using Telnet mode, per the info:

ATDT"[HOSTNAME]:[PORT]" : Adding a T modifier causes connection input to be translated per TELNET during the streaming session.

So, it could be that Zimodem supports more Telnet than I do. You could try using your Zimodem based WiFi modem with ATD instead of ATDT as that seems to use RAW mode instead of Telnet mode. It would be good to know if that works or not. That would tell me right away this is a Telnet issue or not.
Hey Jim, I sent you a PM with a link to the terminal software, Telemate 4.21, as it was and still is highly celebrated for its high compatibility for proper ANSI rendering in DOS.

I tried Onyx again and it still doesn't work properly.

I used ATD on the Zimodem and the ANSI rendering for lightbar menus and navigation on Mystic based BBSes still works properly just as with ATDT.
OK, thanks for confirming. I am not sure what to think. The ONYX BBS fails as you describe on my PC with every terminal program except NetRunner, where it works perfectly - all without a WiModem232.

Users browsing this thread: 1 Guest(s)