odd thing..
I am trying to set my AT*offhook

I do it.. AT*offhook=blash blah blah

I do AT&W to save the settings.. after an ATZ.. its gone. 

I am on v5.11

Hmmm... I will look into that. Maybe AT&W is not actually saving the setting.
Jim, remember our conversation about this? I have the same issue.

Under BBS Express! ST, when it resets it wipes the command. I
finally put the command in my F10 MDM (modem) file that is
executed when I exit the BBS and then it sets the command with
the WiModem232.

As a short term fix James, do you have a file that's executed when
you exit your BBS software? If you do, you could put the offhook
command there.

HTH's. Smile
I thought this was fixed with v5.11? I will take a look later today.
Ok, I just fixed this issue and released v6.01. Please update your firmware!
WOW.. service.

Thanks Jim.

I'll second that!  Smile
However, after applying the latest update it still doesn't work here.

Whenever BBS Express! ST exits, it does something that clears that setting out.

I can get around it by putting the actual command into the F10.MDM file that is executed when the user presses the F10 key and exits the BBS.

So it works, just not as intended here.

BBS Express! ST just seems to be the poster child for problems. Smile

Another strange thing it does to me is that at night it "polls" the time and at the top of the first hour after 12am it executes a file that does a bunch of maintenance stuff. While it's doing this, it sends a command to the modem that takes it offline, but doesn't utilize the WiModem232's "busy" message. It just goes offline and anyone trying to call in gets a big fat blank. Like I said, the poster child for problems.

Thanks for trying though Jim, very much appreciated...
Well both of my BBS software has ATZ in the modem initialize routines. Those routines are used everytime a call is hung up. So storing the setting with AT&W is really the only way it's useful.
What might be an interesting setting or option is, having a msg sent to the caller if the computer does not answer after so many rings ... Aka the BBS has crashed and the modem is still functioning.

I just tried this again and it works fine here. Storing the OFFHOOK string using AT&W and then sending ATZ shows the OFFHOOK string just fine. You might try that to verify that you aren't changing the OFFHOOK message somewhere in your BBS initialization. Also, check to make sure you are using the v6.01 firmware (use ATI).

There already is a message that is sent to the caller when the BBS does not respond after 10 ring attempts (10 seconds). That message is hard coded to say "AUTO-ANSWER TURNED OFF!" I did this for cases where the BBS has crashed.

Users browsing this thread: 2 Guest(s)