TP-Link and WifiModem issue
Hello everyone,

I need a bit of help Sad
I recently purchased the wifimodem and I know it works because it connects to my phone without issue.
However, I cannot get it to connect to my TP-LINK router.
I've tried removing encryption, turning off the firewall, making password all caps, not all caps, (tried password in caps and not for each test).
No password etc.. always says cannot find router.

AT*N will detect my router (shows 3 SSID's for my router with same name) 
However when I try to connect using any of the 3 methods listed in manual, i get No router located including WPS.

After failed attempts, if I do API command it does show that it's connected to the router but no IP address.
The router under connected devices however does not show the mac address of the modem.

This is a mesh network with 2 extenders.  I have tried both 2.4 and 5ghz as well.

Any ideas?
You have to use 2.4GHz as the WiModem does not support 5GHz at all. I actually use a TP-Link router myself. It's not a mesh network though. If you are using one of the Deco units, this is a known problem. You can look at this for help:
Thanks for reply, I don't have one of those Deco units. Mine is TP-Link AX6600 WiFi 6 Router and I did set up a guest network at 2.4GHZ and although it finds it in search it simply won't connect to it.
I can't whitelist because it needs IP address and the device has none until it connects.
Is there anything I have to do on TP-Link to allow access from this device?
I didn't have to do anything other than simply setup a wireless access point in the router settings.  I am using a C5400.

Attached Files Thumbnail(s)

Users browsing this thread: 1 Guest(s)