Downloading problems with WiModem 232 and a UDS-10
#91
The change was made to the buffer handling (the buffer offset was only a byte wide instead of being a word wide), and that affects Zmodem as well as any other fast protocol (or even transfer) that sends more than 256 bytes. Glad to see it is working for you as well.

You will ALWAYS want to have hardware handshaking enabled (AT&K1). I probably should make this the default setting.

I have my buffer limit set to 4096. Anything over 1024 didn't seem to make much difference, but there was some. 512 seems to be about the minimum you should use for anything higher than 9600 baud which is why I bumped the default to 1024.

You need to send a ATH1 command to enable the OFF HOOK mode. Once you do that, the OFF HOOK message string will appear and the modem will never answer. Put it back on hook with ATH0. You will know right away if you don't have ATH1 enabled because the display screen will show OFF HOOK for the SSID, and the auto-answer flashing of the LED is disabled. You never know that someone has tried calling.

AT*HELP! has the new command (AT*OFFHOOK=), but it is not in the normal AT*HELP because the text is wider than the spacing that is made for each column of entries (designed for a 40 column display).
Reply


Messages In This Thread
RE: Downloading problems with WiModem 232 and a UDS-10 - by admin - 11-07-2022, 09:40 PM



Users browsing this thread: 9 Guest(s)