card not found error
So I've had my SCP for a while (3 yrs), I still have the same PC I used it on 2 years ago, pulled the SCP out of moth balls and tried to use it, but after installation on the same PC, it says the card cannot be found. Yet the FTDI driver installs just fine, and when you plug in the card, windows 7 64b gives a "thumbs up", and the SCP starts the red led, turns to green, and the "USB" led turns on, but the SCP software reports the card not found. Taking the original zip file to another older Dell Inspiron 20 running win 10, it installs just fine as in the 7 64b, but complains of course about the missing dll file - I installed that on the win 10 and then it sees the card just fine. I also use Arduino on the Win 7 PC and no issues with serial connections. I do use a hub extender but I also tried it direct to the PC without the extender. Removed all unnecessary USB devices but I am met with the same results. I am not sure where to go from here as this used to work on this machine. Is anyone aware of any USB software drivers or apps that might conflict with this driver?

Thanks to all....
Howard 73's de W1ARQ
Sounds like the registry or USB driver is corrupted. Have you tried checking your machine with some diagnostics program? I use CCleaner myself to check the registry.

Users browsing this thread: 1 Guest(s)