WiModem232 on Apple //e with SSC no longer displays any output
I've got something weird going on that I'd love a little bit of help with.

Without any configuration changes to my Apple //e or my modem, my rev 2 LCD WiModem232 on my Apple //e stopped initializing in ProTERM 3.1.  In other terminal programs such as AGATE and ZTerm, the modem wasn't generating any output to the screen.  (No response to commands such as ATI, and no local echo of what I type, and if I connect to a BBS, no output to the screen)  I can tell that the modem is receiving commands, because I can type commands like at*swap and atdtgoogle.com:80 and I can see the LCD screen respond.  I can even do +++ to get into command mode and ath to hang up the connection to the whatever BBS I am connected to. But, there's no text output of any kind, before, after, or during the connection; The only way I know I'm in command mode or disconnected is by looking at the LCD screen on the modem itself.

I figured before I jumped down the rabbit hole I'd start from zero.  My modem was a number of firmware revisions behind so I used ZTerm (a generic terminal program) and I performed a firmware update to the latest version.  Even though I saw no text output, the update was successful.  I then performed a full emergency reset (where the LED rapidly flashes between two colors after jumping those two pads when applying power to the unit and keeping them shorted for ten seconds) and reset my terminal program to 300 baud.  I then double checked that the DIP switches on my Super Serial Card were identical to those shown in the https://www.cbmstuff.com/forum/showthread.php?tid=477 thread, following the setup process exactly as described.  However, even after typing AT*D1&C0&W in terminal mode, the modem still shows no output of any kind.  It accepts commands as described above, it connects, but the modem never sends a single character to the terminal screen, regardless of which terminal program I use.

I had a problem similar to this back in Firmware update 2.70 that I posted about here but this doesn't seem to be the same thing, because all combinations of *Dx and &Cx don't seem to change the symptom.  I have another known-good Super Serial Card, so I swapped that one and it's cable and bracket into my //e but the symptoms did not change.

I have a second WiModem232, a known-good Rev 1 LCD model that lives on my Apple IIc currently. I moved that known good modem over to my Apple //e and got the same symptoms.  Then, to be thorough, I tested my Rev 2 modem on that IIc, and I got different symptoms, where the modem would initialize and I could see output on the screen, but I couldn't successfully connect to anything over Telnet.

I'm not sure if I'm doing something wrong from a software and configuration standpoint that's over my head, or if it's time for me to buy a new WiModem232.

Any advice for me?
- Jarrod Kailef, Wearer of Many Hats

[Image: SignatureRow.png?raw=1]
Well, the "modem" is not actually responsible for outputting anything to the screen.  It can only send/receive data through the serial port.  So, this is an Apple side issue.  I ran into this same problem while setting up my Apple //e for Kansas Fest.  That is why I added the text in bold RED in the thread that you linked to.  The issue is typically to do with the SSC dip switch setting and the driver you are using.  Some drivers, especially at 9600 baud don't require any changes.  Some drivers do require dip switch 7 to be changed from what is shown in the pictures in that thread.  Check out that thread again.  Also, I noticed you are using a V1 and have different results from V2.  THAT is to be completed expected if you didn't cut the traces and add the jumpers as discussed in the thread.  For the v1 WiModem232's this was NOT an option for Apple II users.

There is never a reason to buy a new WiModem232 just because you have an issue.  There is a lifetime warranty on every electronic device that I produce, so if there is something wrong with it I will replace it.  You just have to pay for the shipping to/from me.  Since I ran into the exact same problem that you did, making me figure out that it was a SSC dip switch issue, I am sure that the issue is that or not having the traces cut and jumpers added.
The thing I don't understand is that it's worked without issue for a year and a half, and I didn't move, add or remove any expansion cards, change jumpers or dip switches, or even update the modem's firmware, and the symptom just "appeared" one day. That's not something I usually see. I even tried using a backup of my HD image that I made a year ago to see if there was some software level change, and I got the same symptoms on my old HD image. So, I'm pretty confident that it's got to be the modem, the cable, or the Super Serial Card, as I am pretty confident I ruled out software by using my backup.

I did try all my tests with bank 1 dip switch 7 both open and closed, and it didn't seem to change the symptoms. I'm at a loss as to what might be happening. I don't have any other serial devices to test the port with, either, just a rev1 and a rev2 WiModem232 and a serial to USB adapter that I use for ADT Pro. (ADT Pro, by the way, works fine, and the rev1 WiModem232 is irrelevant as I'm specifically trying to fix the rev2 WiModem232 on my //e)

As I mentioned, I ran into a similar issue a few years back when I updated to firmware version 2.70. This doesn't seem to be the same thing, because all combinations of *Dx and &Cx don't seem to change the symptom.

Truth be told, I'm kind of pissed off. For six hours today, I've been reading and re-reading that post and double checking every DIP switch, and every character I'm supposed to type, repeating the instructions over and over again, with absolutely no change in symptoms whatsoever. At this point I'm incredibly frustrated. I'm sure I'll be less upset later, but at this particular moment if I took your advice and "Checked out that thread again" I expect it would result in my tossing the equipment off the balcony. Wait, I don't have a balcony. Never mind, you get the idea. :-)
- Jarrod Kailef, Wearer of Many Hats

[Image: SignatureRow.png?raw=1]
Do you have another computer you can test the WiModem232 with (PC, Atari St, Amiga, etc.)?  When I saw this problem with my Apple //e it was using a WiModem232 with v2.10 firmware.  I updated it to v3.04 and the issue was still there and after playing around discovered it was the SSC and particular modem drivers where the auto-echo worked or didn't work as you would think.

If your setup worked (and there really has not been ANY change, like a new board, joystick, cable, reset of modem after saving some changes, etc.) and now it suddenly doesn’t work after over a year, then something hardware wise has failed.  The WiModem232 plugs directly into the SSC so there is no possibility of a cable failure (unless for some reason you are using a cable?), so that leaves the SSC itself, the Apple computer, or the WiModem232 that has failed.

Again, it’s the terminal program that displays text, not the WiModem232.  You could trying sending a command to turn on the auto-echo to see if you see text at that point.  Send the command ATE1 to the WiModem232 and see the results.  It could be that ATE1 was stored and was altered?

I can certainly test your WiModem232 and swap it if it’s bad.  Since you are able to send commands and have the WiModem232 respond I really think this is just a configuration issue of some kind.
(11-27-2020, 12:14 PM)admin Wrote: Since you are able to send commands and have the WiModem232 respond I really think this is just a configuration issue of some kind.

I'm reasonably confident that it's a configuration issue as well, but all I've got is a bunch of Apple systems to test with.  I'm going to give another shot to figuring it out this weekend.
- Jarrod Kailef, Wearer of Many Hats

[Image: SignatureRow.png?raw=1]
First thing to try is sending ATE1 and see what happens.
I tried that yesterday, and the result is really, really weird.  As expected, since ATE1 just turns on local echo, I still don't see any data coming from the modem with regard to inbound characters from a remote server, or the responses to my AT commands.  I DO however see the characters I type echoed back, except....  This is hard to explain - They are delayed by a single keystroke.  Here's what I mean.

For example, if I type AT, I will see:

on the terminal screen.  If I type ATDT I will see:

on the terminal screen.  It's really weird.

If I type AT<ENTER> I will see:

on the terminal screen, with no linefeed.

I have no idea why that would happen.  It's really strange because I can't possibly imagine how the characters appearing on the screen would lag behind what I'm typing by a single keystroke.  Some sort of buffer somehow?  I don't get it.
- Jarrod Kailef, Wearer of Many Hats

[Image: SignatureRow.png?raw=1]
Yeah, that is odd... but it does prove the that transmit and receive of the both the serial port and the WiModem232 are working. I have seen all kinds of issues with ProTerm like this, and I could only get ProTerm v3.1 to work at all. I couldn't get the earlier version to work with my real modem! You have multiple SSC's and Apple II's right? Do they all do the exact same thing?
A friend of mine sent me a known-good super serial card and a known-good WiModem232 Rev 2. I get the same results on my Apple //e. By the way, I've done all my testing using a raw Terminal program (ZLink) rather than Proterm. (But it does the same thing in Proterm)

I swapped out the only thing I hadn't changed yet, using another serial cable, and it still didn't change the symptoms either.

So then I tested this new, known-good WiModem232 on my Apple IIc, and it's working fine there. So for grins I connect my old WiModem232 to the Apple IIc, and lo and behold, it's working fine as well. Pardon me while I take a moment to whack my forehead against my desk a few times.

Clearly, I've overlooked something, so I must assume that all of my testing up until this point is faulty. Time to start over from scratch with no assumptions. I have absolutely no idea what's going on!
- Jarrod Kailef, Wearer of Many Hats

[Image: SignatureRow.png?raw=1]
Wow.. that's weird... maybe corrosion of the contacts of the socket for the SSC or serial cable? Did you try moving slots?

Users browsing this thread: 2 Guest(s)