What am I doing wrong ? Disk Media Test
There has NEVER been a change to the any of the drive utility code, so the version won't matter. The results will always be the same.
Uh, yea there was. In 1.91 and earlier the media tester wrote the same pattern to each track. In a later version you changed that to write different randomly selected patterns on each track. I forget what issue that was supposed to address (something about the test passing if a wiped disk was placed in a drive where writing was not actually occurring, I think), but some patterns randomly triggered a verification error on my system. As I recall you looked at some dumps and found some issue with a brief pulse of noise at the splice point/end of writing, and blamed my drives for it.

The problem he described sounds similar to how mine behaves with the 1.97 software. So when I need the media tester, I just use the old version, and that does what I need.

I see there is a brand new version out, I have not tried that one yet.
The code to write is the same.  The output pulse duration is selected randomly for each write instead of having the same exact 4us pulse each time.  You should definitely NOT use the older version because it can show false positives.  If there was a failure to write at all (like a SCP hardware failure), reading the same disk would always show the write was successful when it fact nothing might have been written at all.

In your case, it most definitely shows the issue with the drive you are using, which should NEVER have the 'red' (no flux area) data stream preceeding the track.  This same thing will happen when writing data to any disk during a copy.  There is only one write routine and one read routine.  Those routines are called by ALL of the functions in the software.
I too have had problems with media test (most recent software version).
In this case I'm trying to validate 5.25" 360K (48tpi) media using a 48tpi drive (TEAC FD-54B IIRC).

I have to change the slider to 40 tracks, and every disk I try to validate fails. Including brand new 3M disks fresh out of new old stock boxes, used media, media with data on it, bulk erased media, etc. So far I have not gotten a single disk to pass.

I have cleaned the heads, and I've written 30+ Atari disks perfectly fine so far.

I plan on trying another drive to see if there is any drive sensitivity, but there have been no issues writing disks. I did have problems with one disk write not working, but when rewritten on another new disk it worked fine (indicating that one disk was bad). I thought I had confirmed that the media was bad using this tool, but then when I tried it on any other disk it also failed.

I have not tried to validate any other media (5.25" 80 track DD (QD), 5.25" 80 track HD, or any 3.5" media) yet.
The test is valid.  You can look at the results yourself by doing the test and looking at track 0, head 0 with the editor analyzer.  Read the track and click on DISPLAY FLUX.  You should see perfectly straight band.  If you see a band that is wavy, then that would indicate a drive speed problem (which would show up as bad media).

You could always do the media test (ignoring all of the failures and letting it proceed completely) and then make an image of the disk and send to me - data @ cbmstuff.com and I can look at it to determine if your media is really bad or if its a drive speed issue.

The media test expects the thin straight band as the test result, and that really needs to occur in order to be able to make good images and disks.  So, regardless of the reason that needs to be corrected.

Users browsing this thread: 1 Guest(s)