Tandy 1000 drive works but no index pulse, reads random noise
I am trying to image disks from a Tandy 1000, via the machine itself. This machine was set up with both a 5.25" floppy and a 3.5" floppy. I haven't done/tried anything with the 3.5" drive, but the machine boots and works off of the 5.25" disks I have with it.

To image the disks, I opened the Tandy chassis and removed the floppy cable from the board and plugged it into the SCP, ensuring that the pink line and tab on the socket matched up with pin 1. I turn the computer on to use as a power supply and plug the SCP into an old Windows 7 netbook I have. When I open the SCP app, both of the drive lights come on in sequence. Track test shows 42 on the 5.25" and 85 [iirc] on the 3.5" drives, everything seems very promising!

But the imaging fails saying "No index pulse detected". I changed the settings to:

DriveType: 5.25" - 48 TPI   (Is this setting important? What exactly does it change?)
Weakbits: Raw
Density: R>Low, W>Low
Index Sensor: R>Ignore, W>Ignore
Backside Control: None

Disk Types: IBM 360K
Copy Mode: Splice   ("Index" also works, even though Index is ignore?! What happens in that case?)
Start: T0 H0
End: T42 H1
Preservation on

When I image from Drive 0 to a file, it proceeds although every box is orange as it fills in. (Is that color meaningful?)

But now the final step, I can't seem to do anything with these images in HxC [or is there a better program for converting DOS-compatible disks?]. In fact in its "visual floppy disk" viewer it seems to be pretty much just random noise, I don't see anything that looks like data or sectors or anything promising.

I tossed one of my many tries up at http://extinguishedscholar.com/temp/tand...e2.scp.zip (update: and now a 96tpi at http://extinguishedscholar.com/temp/tand...ks.scp.zip) if you'd care to take a look. Tons of newbie questions already, but my main ones boil down to:

1. Is it expected that an old 5.25" drive in a Tandy 1000 wouldn't have an index sensor, or is that the first thing to troubleshoot?
2. What would cause the drive to "work" but yield only random data? Could the Tandy cabling be different than the SCP expects? [Seems pretty normal cable looking at it.]
Update/addendum: I went ahead and pulled the drive out of the machine to try it with the CBMSTUFF cable that I ordered with the unit.

Drive is labeled as a TEAC 14733700-00 J4-5080 SP68-40248-84

[UPDATE: just set the drive down and found another sticker. It's an FD-54B-02-U which does find a bit more info online, including http://www.vcfed.org/forum/showthread.ph...eac-FD-54A which actually claims the 54B is a 96tpi unit.]

It has seven available jumpers:

IU [on]
DS0 [on]

I couldn't find a datasheet explaining these, though obviously the DSn ones would be drive select and I'm guessing HM/HS are the typical motor via "motor on" or "drive select". Some Googling says "IU" might just be "In Use" for the LED.

(FWIW, I noticed the Tandy cable does not have any twist, although the 3.5" drive does have an edge-card adapter board with at least some sort of transistor/regulator-type component on it that may also take care of the twist. I haven't pulled that drive yet and I don't have any of that size disk handy atm either.)

Anyway, the result of testing the 5.25" TEAC when connected to power and the only drive on the CBMSTUFF cable is the same: it's recognized, and lights up and makes happy klackennoisen but still "no index pulse" and apparently random data. These disks do have the usual index window and, again, everything about the vintage bits has so far been working fine when I use the disks and drive in the Tandy 1000 itself.
BOTH LEDs should not turn on at the same time. That means that both of the drives are selected at the same time. I went through the same mess with the EPSON dual drive (3.5"/5.25). I finally figured out from trial and error what jumper settings worked. The issue I have seen with these and a few other drives is that the motherboard was made so it required a particular jumper arrangement for DS0/DS1/DS2, deliberately so that a normal drive would just not "drop in". Back in the day, manufacturers wanted you to buy their drive, not use someone elses.
No, sorry that's not what I meant. When the SCP app is loading first the 5.25" light comes on, then the 3.5". And in my second test, I'm still having the same problem when this drive is the only one on the cable from your webstore, using the closest position (before the twist).

The drive works fine with the Tandy 1000 controller, just re-confirmed after putting it back on the original cable and plugging that back into the machine. Anything else to test? I do have some electronics tools (DMM, oscilloscope, etc.) but hoping it doesn't come to that already :-)
Sure, it probably works fine because the jumpers are on the drive are set to match the motherboard, deliberately set that way to prevent someone from easily purchasing a standard PC drive and using it without the same hassle you are going through right now.  You need to figure out what jumpers the drive requires for a normal PC,  which is what SCP uses.
Is the behavior I describe expected in that case? The drive spins and the head steps exactly when expected (and sits quiet when not in use), I just don't seem to get any data *back* from it.

Given that the motor already runs when needed afaict (listening) I'm not sure what other jumpers would be necessary besides the "In Use" and "Drive Select 0". I don't think the drives were anything special. For example, http://www.oldskool.org/guides/tvdog/1kfaq.html#II.C.5 says:

> The original 1000, A, HD, EX, SX, and SL use standard 360k floppy drives.

That said, is there likely to be any harm in playing around with one or both of the HM/HS jumpers? A non-spinning spindle motor could certainly explain the symptoms (though not the noises) that I get when trying to image.
I have seen all kinds of crazy things, especially with the really old 5.25" single sided, 48 TPI drives. So, nothing surprises me. The DSO/DS1 and other similar lines all have to be set correctly. Generally, you have DSO open, DS1 close, and DS2/3 also open.
Got it — must have only been imagining motor noises! With the SCP, the motor only comes on if I add jumpers to both HS and HM (whatever they actually are). Once that's actually spinning, the index pulse is found and the result shows up in HxC.

Imaged a whole bunch of disks tonight with pretty good success across the ones I checked. It goes a lot quicker than I imagined, especially in Indexed mode. Had to make sure the Index Sensor was set back to Require as HxC as the "ignore" ones were not coherent even in that mode. Thanks for the jumper tips!
No problem! I don't know what half of the jumpers do. I just know that some computers were deliberately made so that an aftermarket replacement drive was not easy to add. Smile

Users browsing this thread: 1 Guest(s)