Can't get it to respond
I finally got the adapter in to get my WiModem232 up and running on my DOS computer.  It's the non-OLED version.  I'm using Qmodem set to 300 baud 8N1 and emulation is set to ANSI.  When I power up the modem, I get a message on the screen saying Looking for router... The led is pulsing red.  Then a few seconds later I get a message saying No router located!.  After that, I can't do anything.  ATI dosn't bring up anything on the screen and nothing I do seems to matter.

What am I doing wrong?

Since you can see text, it is likely that your cable or adaptor is correct. Make sure that you have RTS/CTS disabled in your terminal program until you verify the polarity required.

I will have to find Qmodem to try it with my PC.
Thanks.  I tried disabling the RTS/CTS to no avail.  I've attached the Qmodem program I downloaded from Mustang Software.

Attached Files
.zip (Size: 621.32 KB / Downloads: 6)
Ok, thanks.
I also tried the Terminal program that comes with Windows 3.11 for Workgroups and have the exact same problem.
What "adapter" are you using?  Have you verified that the COM port is working (able to transmit)?
I got a regular 9 pin to 25 pin cable and a 9 to 25 adapter.  Both give the same results.  I've also tried two different com ports.  I put on a simple serial port analyzer and it shows a response when I type so I know it can transmit.

Is it possible I have a bad modem?
Not likely, I have to program and setup each WiModem232 by hand using my Amiga 1200. We can try replacing it, but it's more likely a settings issue or a wiring issue with your cable. You may find that you have to change the DCD behavior or cut the DTR/DSR jumper on the WiModem232 itself if your terminal program requires DTR and DSR separately. My PC uses a PCI-E serial card and no changes were required with HyperTerm. QMODEM doesn't work under Windows 10, so I can't test it.
Ok.  I'm going to try another DOS computer.  I need to pull it out of storage but I'll let you know how that goes and we'll go from there.

Good news!!! I got it to work. It was a combination of three things. The serial port I was using was bad, the com port cable from the motherboard was bad, didn't set the IRQ for the com port in Windows 3.11 and Qmodem doesn't recognize off IRQs for comm ports. Downloaded BananaCom, set the motherboard for com3 IRQ11 and it picked it up just fine.

Thanks for your time.

BTW... Is it possible to order the OLED display after the fact and solder it on?

Users browsing this thread: 1 Guest(s)