SSIDs with underscores
Just a heads up for other people that have a "_" (underscore) in their SSID name...

They're not supported in older versions of the firmware. So when you first get your device and you can't connect up and you happen to have an underscore in your SSID - change your SSID to something simple. Then connect up as normal, then update firmware, then change your SSID back to what it was, and then re-setup with your fancy SSID with the underscore. For me, I like to have _optout at the end of my SSID because I don't like Wifi Sense (Win10).

This was true for me on the WiModem232 and the WiModem (C64).

Both great products!
Underscore characters have always worked, it is space characters that do not.  You can always use the AT*NSx command to select any SSID (even those with space characters).
I'll not flood both threads.

I have to say, that just not my experience with either device.

Even though both devices could easily find my router's SSID with AT*N (ATN) commands, and display

It took me a while with the WiModem to even fall across it might be the underscore. Since, WPS wasn't working for me, and there's no underscore on a C64 keyboard (I'm rather new to C64s), my only way to try manually was the AT*NSx command. As soon as I removed the underscore, WPS worked, and so did AT*NSx. After upgrading the firmware, and putting the underscore back in, WPS and AT*NSx commands worked as expected.

I had the same problem again with the WiModem232 while being used on an Atari ST. AT*N showed my router, but AT*WPS, nor AT*NSx would connect to that SSID. After removing the underscore - again all commands worked as normal.

I'm not going to say my SSID and password, but I'll give your the lengths of them, if it's something to do with that instead.

SSID: 1234567890123_optout
PASS: 12345678

My connecting up the devices wasn't just I tried a command and it didn't work. I was scratching my head for a good 30 minutes, double checking and triple checking I was entering the commands and passwords correctly.

Removing the underscore I found to be the only fix.
That must be a problem with your particular router. I use space characters in my router's name and WPS as well as AT*NSx works. What router are you using? I use both Cisco (LinkSys) and TP-Link routers for connecting to the WiModem and WiModem232 here.
I've got a TP-Link Archer C3150 and a TP-Link RE450.

I've got a few other devices that are 2.4GHz only, and they worked fine with the underscore from the get go.
I am using the TP-Link C5400 here with no issues!
All I can say is - I had the same issue with both devices, and it was fixed after removing the underscore, updating the firmware, and sticking the underscore back in.

If it's not the old firmware, but the router/extender I have, then it's still something that people might want to keep an eye on, if they're having problems connecting up for the first time.

Though, I guess newer customers will be getting newer firmware versions than I got anyways.
There have been no changes to the router connection portion of the code in since 2016, so I can't imagine any recent change to the firmware would "fix" this, and nobody has ever reported a problem with WPS not working.  That's an industry standard, so it was important that the first version of the WiModem for the C64 supported it.  Maybe your router had a glitch of some kind?
This has been my experience also. I cannot connect to my router if it has an underscore in the SSID. (2010 Apple Airport Extreme)

Is there more than one type of underscore character? Does the underscore character produced by an old Apple II keyboard somehow differ from the underscore keyboard produced by a modern Mac thereby producing the wrong SSID in the WImodem232? Doubtful, but possible.

I have not yet commanded the Wimodem232 to update its firmware, but as delivered it will not connect to my router with an underscore in the SSID.
Well, that's unfortunate. Especially since I can't control that. That's part of the WiFi library for the ESP8266 device. Maybe there is some sort of issue with the exact ASCII character being used for the underscore, but I doubt it. You are suppose to be able to use characters 1 through 255 for both SSID and passphrases.

Users browsing this thread: 1 Guest(s)