Possible Bug
I got my WiModem232 and I think its great, absolutely love the display.

When I do the AT*N it says that it finds 14 networks and starts to list them gets to about 5 and reboots.

Now I was able to set it up using the AT*SSID command, but wondered if it was something wrong on my side.


[Image: WiModem232.jpg]
Was this at 300 baud? I will look into it.
Did you know you can remove the protective covert that is over the OLED screen? I probably should make a note of that in the manual.
Yes I know I can and I will once I print a case for it (wait for that file). Yes I was at the 300 baud - like I said I was able to make it work with the other command but the SCAN function did not work correctly.
OK, I have fixed it. You can update the firmware to test it.
Yes that worked fine, thanx
Great! We don't normally use 300 baud (or 14 different routers), so it has never come in last few years that the WiModem has been out.
Well the 14 APs I understand, but the default on the WiModem232 is 300 baud, so I left it there on the initial setup. I have it running at 9600 baud.
For nearly two years, the default baud rate of the original WiModem was 2400 baud.  That changed just a few weeks ago, so this was never a problem before.  When too much text is output via serial at a low baud rate without allowing the WiFi stack to do house keeping, the RF module will reset.  Just one of those "features" of the RF module you have to work around.   I need to go through the code again and see if there are any other possible cases where this could occur.  If you see anything else odd, just let me know and I can easily fix it.  The update feature is our best friend.  Smile
I just played with my WiModem232 today and found some interesting things.

I have it hooked to my Tandy Model 102 with a 25 pin male to male serial cable.

1. I could not get reliable communications over 600 BPS. When I tried anything faster than that, I got dropped characters.
2. My WiFi password is something like "Some really long sentence that's easy for me to remember?". The SSIS contains no spaces. It would not connect to my WiFi until I shortened the password.

Other than that, it works just fine. I connected to a telnet BBS without any problems (other than the small-ness of the my T102's screen 8) ).

Has anyone else gotten communications > 600 BPS with a Tandy 102?

Users browsing this thread: 1 Guest(s)