Striketerm UP9600 freezes with WiModem
Well, I've done a number of tests.  When selecting UP9600 as the modem in StrikeTerm 2014 Final it always froze loading the driver.  To make it work I had to start Striketerm without the WiModem plugged in.  Select UP9600 and save the config.  Then restart with the WiModem plugged in.  I also set my protocol to Zmodem and the terminal to ANSI.  Not sure if that makes a difference.  But I could not change to UP9600 with WiModem plugged in.

Works now, and super fast file transfers with WiBridge.  Big Grin
I am not sure where the problem is. Previous versions of StrikeTerm don't do this, but NovaTerm does hang during the driver selection as well. I have verified that the hang is not associated with the WiModem itself, it's something in the C64 code, I believe with the UP9600 detection routine because CCGMS has different code for this and has no problems.

This same issue has been reported for other Wifi modem and PC interfaces.
I finally got Novaterm 96 set with the correct serial driver, baud rate, and modem type (not critical I'm sure) without freezing up but I'm still having trouble getting online. I keep getting a "No answer" response on the WiModem. I have tried Inverted and Normal carrier detect settings. Striketerm2014 allows me to dial from the phonebook and go online but I had trouble with just using atdt xxx in terminal mode also. I am using the UP9600 driver.

I would prefer to use Novaterm96 if possible but I have yet to be able to make a connection to any site.

Alwyz' CCGMS2017v6 is nice for its small size and telnet-friendly dialer, but it is missing REU support for a download drive.

So far, these three programs seem to be the best fit for WiModem use but they all have issues.
Yes, thats right...
I have the same problems at all :-(

I prefer CCGMS2017v6, but i miss also the REU Support.
NO ANSWER is just that - there was no answer to the connection.  This is either due to the connection being down, or the wrong URL and PORT being used.
But I've tried multiple sites. I know they're not all down at the same time. Smile

You do raise a good point about the URL format. I have tried "site.domain:port" and "site.domain,port". Which is the correct syntax? When I look at the WiModem display when using CCGMS' dialer and it successfully connects, I see the comma. When I use the same format in terminal mode in Novaterm, it does not connect.
As shown in the manual the correct syntax is:


The port is optional.  If you don't include the port then the default output port will be used.  The default port is 1541.  Example uses:


This will connect to Commodore Server using port 1541.


This will connect to Google's server using port 80.  You can't do anything with it, it's just an example for connection.

Also keep in mind that you MUST be in ANSCII mode when dialing, and characters must be in upper case (as shown in the above examples) OR, if you are in CBM graphics mode you have to type the AT strings in all lower case.  There may be some cases where this doesn't always work, so it is recommended that always dial in ANSCII mode.
I'm always in CBM graphics mode.  Smile  I'm not familiar with ANSCII. Is that some hybrid of ANSI and ASCII??

Sure enough, the WiModem is responding well to the ":". Novaterm's dialer isn't always working, however. Sometimes the WiModem just ignores it. It does not help that the phonebook has limited character space. I can understand. It was only originally designed for phone numbers. This is one advantage that Striketerm has over Novaterm. Part of my confusion about the "," vs ":" usage comes from other platforms. On my Amiga and in my Mac terminal window, you use the comma but I know I saw the WiModem echo back the use of a comma on a successful dial. It might have been Striketerm or CCGMS2017. I will need to verify that.

I decided I would start with a fresh 1581 copy of Novaterm 9.6c I remembered I had. I made a backup first. When you boot without an existing config file, it will run a wizard to step you through it. The defaults chosen were close to what I already had but something may have changed for the better. I will get to that in a bit.

Starting fresh, I was hoping maybe I could avoid the freezes when changing some settings but it still froze when I tried to change the download protocol. I removed the WiModem, booted Novaterm back up and was able to change all settings without it locking up.

I chose Xmodem as the default protocol since I've had the most success with that. I tested a handful of sites, connecting through terminal mode. I did some test downloads and was surprised to receive zero retries. Not sure yet what helped here. Perhaps due to the 1581's somewhat faster serial speed? I'm using the stock ROM kernal, mind you.

I tried switching to Punter while already in terminal mode (C= P in Novaterm) and to my surprise, it allowed me to change it without freezing! I also successfully completed a Punter download without errors.

I will next want to try Multi-punter downloads. Hopefully I can change to that protocol without freezing also. Since Novaterm and Striketerm both have problems with settings changes while the WiModem is installed, any idea what might be going on here?

Getting back to my error free downloads thus far-- I should mention I have been connecting to sites claiming to support speeds above 2400 baud so I know it is not due to a slower connection speed. It might be the Hardware flow control setting that was enabled by default from the Novaterm wizard. I already knew this was a possibility that would help but from the posts I've read, I was not certain if Software flow control was the better choice for the WiModem.

This next question is not WiModem related but perhaps someone can answer. I could have sworn Novaterm had a configuration setting that allowed you to use the REU as a download drive and not just as buffer space. I cannot seem to locate where to set this up. I remember back when the Swiftlink was introduced, there was talk saying this was a must if you were to going to download with connections above 9600bps since the 1541 could not keep up.
You have to set the FLOW CONTROL (not to be confused with transfer protocol) to Xon/Xoff with Striketerm - that actually selects RTS/CTS.  There is a bug in Strikesterm where these flow control options are backwards and this causes the freezing.  It has nothing to do with the WiModem, it occurs on any user port serial device as well.
Thanks. I will have to remember that with Striketerm. With Novaterm, Hardware flow control seems fine.

Users browsing this thread: 1 Guest(s)