Strange ERROR message on connection
(03-09-2019, 07:23 PM)admin Wrote: Where exactly do you see the error message?  Do you see this only once, or every time you attempt to connect using the ATDT command? The WiModem232 accepts either CR of LF as the "enter" for a command.  If you send random characters (visible or not) followed by CR of LF, you will definitely get an ERROR message returned.  For example, if you typed some control characters (which are not visible on the screen in a terminal program) followed by CR, you would get an ERROR message.  What terminal program are you using?  How do you have your setup configured (it should be 8N1).

The ERROR message appears on every ATDT or ATDP command.  I am typing my commands manually, using the Tandy Model 102 TELCOM application, which is about as basic a telcom app as you can get: every typed character is sent to the remote system verbatim and the only intercepted characters are XON/XOFF, for flow control.  I have the comm settings at 38N1D, which means "300 baud, 8N1 format, no XON/XOFF flow control".  I don't think the Tandy 102 looks at the DCD line.  It might examine DSR - not sure.

I've also waited until I had solved the error message thing.  It occurs when I have extended response control (ATX) set to ATX1.  With ATX0 (default), the message does not appear and I get CONNECT instead of ERROR.  You can mark this one as solved now!


Messages In This Thread
Strange ERROR message on connection - by brooknet - 03-09-2019, 07:03 PM
RE: Strange ERROR message on connection - by brooknet - 04-29-2019, 11:12 AM

Users browsing this thread: 1 Guest(s)