CBMSTUFF FORUM
Apple /// and WiModem232 - Printable Version

+- CBMSTUFF FORUM (https://www.cbmstuff.com/forum)
+-- Forum: CBMSTUFF PRODUCTS (https://www.cbmstuff.com/forum/forumdisplay.php?fid=1)
+--- Forum: WiModem232 (https://www.cbmstuff.com/forum/forumdisplay.php?fid=79)
+--- Thread: Apple /// and WiModem232 (/showthread.php?tid=626)



Apple /// and WiModem232 - retrobecanes - 06-10-2019

I have been trying to use the WiModem232 with my Apple /// via its built-in RS-232C port and the results have been...'mixed' at best.  First in terms of installation, I am plugging the WiModem232 directly into the port via a gender changer, i.e. no cabling involved.  In terms of Apple /// software, I use XModem ///, set to 300 bauds, 8 bits no parity, half duplex an line feed.  I can tell that the WiModem232 is receiving the commands sent from Xmodem /// as an AT*UPDATE will trigger the firmware update as expected.  However none of the other AT commands (e.g. AT, ATI, etc.) output any messages to the screen.  The only thing that works as expected is ATDT which enables me to access a BBS, e.g. a80sappleiibbs.ddns.net:6502.  The only problem once I am connected to a BBS is that it seems that auto-echo is enabled as each character that I type on the keyboard is repeated on the screen.  Has anyone had any luck connecting the WiModem232 to an Apple ///?


RE: Apple /// and WiModem232 - retrobecanes - 06-12-2019

(06-10-2019, 02:51 PM)retrobecanes Wrote: I have been trying to use the WiModem232 with my Apple /// via its built-in RS-232C port and the results have been...'mixed' at best.  First in terms of installation, I am plugging the WiModem232 directly into the port via a gender changer, i.e. no cabling involved.  In terms of Apple /// software, I use XModem ///, set to 300 bauds, 8 bits no parity, half duplex an line feed.  I can tell that the WiModem232 is receiving the commands sent from Xmodem /// as an AT*UPDATE will trigger the firmware update as expected.  However none of the other AT commands (e.g. AT, ATI, etc.) output any messages to the screen.  The only thing that works as expected is ATDT which enables me to access a BBS, e.g. a80sappleiibbs.ddns.net:6502.  The only problem once I am connected to a BBS is that it seems that auto-echo is enabled as each character that I type on the keyboard is repeated on the screen.  Has anyone had any luck connecting the WiModem232 to an Apple ///?

Many thanks to Jim for his assistance with this issue.  To make a long story short, the problem was fixed by issuing the AT&C0 command from the terminal software (Xmodem /// in this case).  After that everything worked as expected with the Apple /// and WiModem232.  The apparent auto-echo issue that I was getting was due to the half duplex mode, that was fixed by switching to full duplex.  So for those of you who have an Apple /// and are using XModem /// with the WiModem232, here is the configuration that you will need:
- connect the WiModem232 to the RS-232 port of the Apple ///c (either via cable or gender changer)
- launch Xmodem ///, go to settings and configure as follows: 300 bauds, 8 bits no parity, half duplex, linefeed yes
- issue the AT&C0 command
- return to the settings and set to full duplex
- issue the AT command and you should be an OK response.  All other AT commands will work as well.


RE: Apple /// and WiModem232 - admin - 06-12-2019

Thanks for posting this. I am sure this info will help someone else!


RE: Apple /// and WiModem232 - Beery Miller - 06-14-2019

I assume once you have things working at 300 baud, you can use higher baud rates with that software? I know I connect at 38,400 baud, but that is with a computer other than an Apple unit.

Beery


RE: Apple /// and WiModem232 - admin - 06-14-2019

I would expect the Apple /// to be able to achieve at least the same baud rates as the Apple ][ with the Super Serial Card (since the Apple /// has that built into the motherboard).