CBMSTUFF FORUM
Terminal program not detect the WIFIModem232 - Printable Version

+- CBMSTUFF FORUM (https://www.cbmstuff.com/forum)
+-- Forum: CBMSTUFF PRODUCTS (https://www.cbmstuff.com/forum/forumdisplay.php?fid=1)
+--- Forum: WiModem232 (https://www.cbmstuff.com/forum/forumdisplay.php?fid=79)
+--- Thread: Terminal program not detect the WIFIModem232 (/showthread.php?tid=484)



Terminal program not detect the WIFIModem232 - adorni - 02-24-2018

I install an terminal program but not detect the modem on any COM port...

How i do wrong?

Thanks


RE: Terminal program not detect the WIFIModem232 - admin - 02-24-2018

You have to select the COM port that the WiModem232 is plugged in to.


RE: Terminal program not detect the WIFIModem232 - adorni - 02-24-2018

(02-24-2018, 01:34 PM)admin Wrote: You have to select the COM port that the WiModem232 is plugged in to.

And... how i can do that?


RE: Terminal program not detect the WIFIModem232 - admin - 02-24-2018

I don't know. That depends on the terminal program you are using for the PC (assuming you are using a PC since you mentioned COM port).


RE: Terminal program not detect the WIFIModem232 - Beery Miller - 02-27-2018

If you are on a Windows PC, Windows will not "find" the modem as the modem is not a USB device.  

Assuming you have a Windows computer, you can have a COM port in one of two most probable ways.  One way, you have an older PC that has a COM port on the card or back of the case.  If that is the case, then you should be able to plug directly into it.  Also, if you have an older PC, there may be a chance you need to go into the BIOS to turn that port on.  Make sure you plugged it into a serial port and not a parallel (LPT) port.

The other option is if you have a newer USB to serial cable.  I've not played with that route.

Myself, I have a newer Windows PC and I bought a serial card for the computer.  I then had to get the correct cable for it.

Also, keep in mind, someplace in your terminal program you will need to initially set the baud rate at 300 baud.

Let others here know what software you are using and what kind of computer you have and they may be able to guide you a bit.


RE: Terminal program not detect the WIFIModem232 - Zeropage - 03-01-2018

I'm currently setting up the wimodem232 on an old compaq armada with freedos.

this is how I found the com port

1) Plug in the wimodem and make sure its powered.
2) At a command prompt do: mode com1 /baudhard=1 (on newer systems you can do mode com1 /status) this will show the current com port settings.
3) If the com port baud rate is > 300 (default) do : mode com1 300
4) Do : copy con com1 (this will redirect console input to com 1)
5) Type AT*RESET , if the wimodem resets, then you've found the com port that the wimodem is on otherwise, repeat these steps for com2,com3,com4 e.g mode com2 /baudhard=1
(use ctrl-Z to exit copy con)
At this point you can use the copy con com1 command to set the baud rate for the wimodem. I had to do this as the terminal program that comes with freedos supports a minimum baud rate of 1200.

Dont forget to AT&W to write the new settings, otherwise it will revert to 300 baud after a power cycle.