Full Version: cant copy my 'secret of monkey island' ?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I have a genuine copy of 'the secret of monkey island' on 4 x disks (Amiga)...which I have imaged to the PC ..
But when I wrote disk 1 back to a floppy it fails in my A600.
The original disk boots no problem ..but the copy does not .
I receive this error ' Monkey 2 has a read errpr on disk block 922'
Thinking it was perhaps a bad disk ..I tried again on 2 more disks.
The same error..?
I re-imaged disk 1 just in case this failed the first time...producing a bad image.
The results were the same.
Perhaps I'm doing something wrong..or perhaps the SCP does not overcome copy protection in this case.
Is the image bad every time..?
Has anyone else successfully archived this game ?
and written it back to real media.
What mode are you using to duplicate/image the disks? Commercial disks should (most always) be duplicated/imaged using INDEX mode.
(08-18-2019, 06:07 PM)admin Wrote: [ -> ]What mode are you using to duplicate/image the disks?  Commercial disks should (most always) be duplicated/imaged using INDEX mode.

Thought I was doing everything right Jim.
Indeed I was very surprised when it didn't work.
here is my scp start screen and the settings I'm using.
I can send you the disk one scp image if it helps ?
It could be that this disk needs SPLICE mode because it wasn't produced commercially, or deliberately off of the index mark.
I will try again using splice mode and report back.
In the meantime I've sent you a dropbox link by PM where you can grab a copy to look at Jim.
But the disks are commercial though a bit grubby see photo
Ok, the disk is definitely copied with INDEX mode. The problem is your drive or that disk. It's really dirty! The drive speed is making the flux data wavy! Are you cleaning your disk drive heads every time you dump a disk? You should be!
Here is a good example of what happens when the disk is dirty - here is disk 1, track 41/head 1 which is part of the directory structure. You can see in the middle of the track there is flux that is destroyed. If this disk boots on your real Amiga then I would say that your PC disk drive needs a good cleaning!
Here is track 0/head 0, which is the boot sector.  The flux is really wavy.  This indicates the disk is having trouble turning in the case.  This can be caused from a bad power source for the drop power (not using a powered USB hub or external power source) or the disk is so dirty that there is a lot of drag.

The flux should be flat, never wavy like this!  I am guessing that these disks make a "swoosh, swoosh, swoosh" (loud) sound when the drive motor spins.
Cheers Jim ..
Ill strip down and clean the drive heads manually..instead of using a cleaning disk this time.
But it may well be that the disks are simply too far gone to make useful images.
A great pity as the reason I got my SCP is to avoid this very scenario.
But too late for some disks I guess.
(insert very sad face)
Well I can't blame the power source ..as you saw in my unit build ..it is a mighty beefy.
I gotta blame the disks which are old and well used.
Perhaps another member has got working scp images they could share of this game.
As you can see from the photo above I do own it ..so not asking for no reason.
Pages: 1 2