Full Version: Dead WiModem232
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi Jim,

The Wimodem232 displayed a firmware update notification this evening (2.94 I'm assuming). Initiated the update as per usual. The progress bar began to increase, but then it went weird and began to fill the entire screen. Purple light was also flashing slightly. Was like this for 15 minutes. Switched it off and then back on and it is now dead as a doornail. Just get a blue flashing light. Included a photo of the screen before turning it off and on again.

Is there a way to emergency flash the device? Thanks.

Yes, you can try to jump the two emergency reset pads BEFORE applying power. If the reset works, then the LED should starting flashing red/blue after 10 seconds. If you don't see anything after 10 seconds then it's likely the RF module itself has failed. You would need to send it back to me and I will replace it with a new one. I offer a lifetime warranty on all electronics that I manufacture.
Resetting has not worked. Tried several times. There is nothing on the screen and there is a tiny little blue LED underneath the screen that just keeps flashing. Its pretty much dead.

It was bought for me by a friend so I will get him to send it back to you for a replacement. I'll get him to get in contact with you for an RMA.
Ok.. that's a dead RF module when the blue LED on the RF module is flickering like that. I have had a few of them. Not much I can do about that because I don't manufacture the RF module. I just replace it when it happens.