Firmware v1.3 issue
#1
Sad 
Hi there,

I am trying to update my SuperCard Pro to the latest firmware. It's currently on v1.2.

Using the updater software, it correctly detects the card and the hardware/firmware versions, but when I initiate the update it just seems to stall as per the picture:

   

Any suggestions?

Kind regards,

Francis
Dreamland Fantasy Studios
http://www.dfstudios.co.uk
Reply
#2
You do have it in update mode, and the firmware file in the same location as the updater?
Reply
#3
(05-08-2022, 09:56 AM)admin Wrote: You do have it in update mode, and the firmware file in the same location as the updater?

Yes, it is definitely in update mode. If it's not, the updater software gives me a message to say the card is not in update mode and quits. The archive is unzipped so all files are in the same folder.

Kind regards,

Francis
Dreamland Fantasy Studios
http://www.dfstudios.co.uk
Reply
#4
I am not sure what would cause the hanging issue, but with a washed out screen like that it typically means that the application has hung. Run the updater in Administrator mode, and check to make sure that you don't have some type of anti-virus program that is trying to block the USB communications. MalwareBytes and a few others can block USB comms.
Reply
#5
(05-14-2022, 04:39 PM)admin Wrote: I am not sure what would cause the hanging issue, but with a washed out screen like that it typically means that the application has hung.  Run the updater in Administrator mode, and check to make sure that you don't have some type of anti-virus program that is trying to block the USB communications.  MalwareBytes and a few others can block USB comms.

It's definitely running in admin mode. I disabled my anti-virus software, and it did get slightly further. Unfortunately the updater software now said that there was a communication error and that the firmware is possibly corrupted. Running SCP shows that the hardware and firmware are now both version 0.0.

Attempting to run the firmware updater again now keeps telling me that the card is not in update mode, although curiously the SCP software tells me it is in update mode.

I'm wondering now if I have bricked the card.  Sad

Kind regards,

Francis
Dreamland Fantasy Studios
http://www.dfstudios.co.uk
Reply
#6
I suppose it is possible that you bricked it. I can reflash it here of course. The SCP software will always say it is in update mode when the USB device driver is present, but normal comms are gone (which is what happens during update mode).

It's rather odd though that this could happen because there are a lot of various safety measures in the bootloader to prevent it from being damaged during a firmware update.

You can PM me for details on getting the board to me for reflashing.

Can you give me details about your Windows setup and version of the FTDI driver you are using?
Reply




Users browsing this thread: 1 Guest(s)