Downloading problems with WiModem 232 and a UDS-10
So, looking at this some more the best course of action might be to make a new string function, like AT*AR=xxx and a mode function, like AT*MODE=x.

The AR string would be just like the BUSY message.. up to 80 characters long. The MODE function is something that I have wanted to implement for awhile now. The default would be 0 (normal), where it acts like a regular modem. Mode 1 would be maintenance mode where it answers on the first ring and sends the AR string, and hangs up. Mode 2 would be offline, where the WiFi chip would be put to sleep, draw extremely low power (and no longer communicating with your router). Issuing a command to the modem would take it out of this mode, back to 0 (normal). So, if you wanted your WiModem/WiModem232 to always power up in lowest power mode and only come to life when you wanted to call a BBS, you could do that using the MODE command. So, I will look at implementing those. I am changing the file transfer guts again because I want to use the newer WiFi core that offers faster speed, SSL, and other features. I am stuck back about 8 versions of the WiFi chip's core firmware at this point. I am also adding a portal so you can setup the WiModem with your router using a mobile device (or your PC if you have a wireless card), instead of using WPS or entering the SSID. There are many cases where people are using characters that are not available on the C64 keyboard as the SSID name or password. This would fix that.
Awesome. Hmm, one thing though - make it have a short "pause" before hanging up after delivering the message.

Reason being, some comms programs, like SyncTerm (very popular) will immediately blow up a dialog box right in
the center of everything as soon as it's D/C'ed. The short pause would give the caller just enough time to read the
message before being blocked/obscured by the popup message saying it's disconnected.

Geez, looks like you've got your work cut out for you with all the new stuff. Smile

Thanks Jim!
OK, I can make a 3 second pause before disconnecting.
That would do it - thanks! Smile
I was just looking at the code and I realize that there is a function I added support for in the v4.00 release, and that was support for ATH1. ATH0 hangs up the modem. ATH1 takes it off hook so it doesn't answer any calls. This is how a normal Hayes compatible modem works. I wonder if I should just make the new option here "ATH2" where it takes it off hook but responds to the incoming caller with the message you can set. Or maybe I should just use ATH1 and if the string is not set then it doesn't answer or send a message, behaving like the normal ATH1 function. I think that makes it more "Hayes like". I remember having ATH1 in the init strings for "go offline" mode of the BBS I ran.
Well, that sounds good. I don't think I use ATH1 anywhere with BBS Express! ST though.
MAJOR UPDATE! I made it so ATH1 is used like you would have done in the past to take your BBS "off hook". You can add a "OFFHOOK" message with AT*OFFHOOK= (just like how the *BUSY text works).

You might also want to try your WiModem232 to WiModem232 uploads/downloads for Zmodem. I found a serious bug due to an improper data type that affected transfer chunks over 256 bytes. Apparently we didn't have hardly any cases where transfers were exceeding 256 byte. See the list of changes in the history.
Awesome! Updating all my WiModem232's now.

I'll report back later. It might be a while, I'm an
election officer in tomorrows election so I have
to be at the precinct station at 5-5:30am...

Thanks! Smile
Good luck with that!
Okay, first off - Zmodem downloads from one Atari equipped with a WiModem232
to another Atari equipped with a WiModem232 is... <drumroll please> SUCCESSFUL!

You did it Jim. Whatever you changed in the Zmodem code now has it working here.

I've got BL set to 1460 and AT&K=1. I'll probably play around with these settings and
see what happens when I lower the buffers or turn &K to 0 (when I've got more time).

But the point is, it's working! I downloaded about a dozen files of various sizes, up to
200+KBs. I did get -1- single CRC error on a midsize file but the comms program almost
immediately resumed the download and it was successful.

But (there's always a "but", eh?). I couldn't get AT*OFFHOOK=" " to work here. I entered
it like this:


But no go. With my BBS software offline, the WiModem232 flashes and says "Incoming Call"
on the LED screen but on SyncTerm, it never gave the "Testing..." message. Is there anything
else I was supposed to set?

Oh, just for quality control, I tried to use AT*HELP and AT*HELP! to look at the new command
but it doesn't appear to be in there. Just letting you know.

But Zmodem downloading WiModem232 -----> WiModem232 is WORKING! Smile Smile Smile

Thanks Jim, really appreciate all your hard work!

PS About the working at the voting station - yeah, gonna be a long day.

Users browsing this thread: 3 Guest(s)