Downloading problems with WiModem 232 and a UDS-10
I actually do have that manual in PDF form, but thanks for attaching it.

I'll look it over and see if I can figure out what pack control and terminal type is and how to adjust it.

Thanks - appreciate all your hard work. Smile
I am going to purchase a UDS10 from an ebay seller so I can look at this myself.
OK, so after experimenting with your BBS and that ZOC8 terminal program I can see that your BBS sends two Telnet codes, but they are only for turning on ECHO and turning off the GA (go ahead) which is common for full duplex systems. The file transfer really does require Telnet escaping. I am not sure exactly what is being sent for the telnet characters. Do you have the ability to send a text file with some part of your BBS, like to read a news page or something from a file? I would like to try to send a binary file like this from your BBS so i can capture it to see what exactly what characters are being escaped and how the replacement is done. If you don't have this ability, it's not a big deal. I am looking various UDS10's on eBay.

What I find odd though is that nobody else is reporting any issues with file transfers (especially since v4.0 was released) with Telnet systems. I uploaded/downloaded literally hundreds of megs of files using various telnet specific (port 23) BBS's without any issues.

I am not sure what makes the UDS10 different. I do know that there are reports on several forums that trying to use two UDS10 devices locally does not work for file transfers, but does work for regular data, the same as you are seeing. I wonder if this is just a setting issue?
I don't think I have that ability (to send a text file). Sorry. Sad

I'm hearing different things. There's a pretty close-knit group of Atari SysOps that hang out ('net speaking, that is),
and we exchange a lot of information. I first became aware of the downloading issue because the people with the
WiModem 232 reported to me that they could not download from DarkForce.

Again, for UDS-10 ----> UDS-10, I've had different results. In fact, I guess that's why I didn't realize there was a
problem until the WiModem 232 owners reported it because downloading or uploading, text files or binary files,
from my Atari Mega STe with a UDS-10 connected, to the Mega ST4 that runs DarkForce, also with a UDS-10,
gives no problems.

I'm wondering if this is just an Atari ST thing maybe? I'm using 19.2k, 8N1 CRC is on...on both machines.

Thanks for all the hard work investigating this, I'm sure it's probably just something silly that I'm doing

PS OH...I tried to download TESTFILE from File Sig 3 with my Mega STe hooked up to the WiModem 232
and it would not do it. Tried a binary file, and of course it wouldn't download it either. Both instances gave
a "subpacket too long" error message on 2 different comms programs that I tried. Sad
I have no issues downloading that file with my A1200 at any baud rate or with C64 WiModem even at 9600. I used Zmodem and Xmodem for the Amiga, and Xmodem for the C64. Are you using the v4.x firmware?

I think this is some sort of translation issue that is not being handled by the WiModem232 because of not supporting any of the Telnet commands (other than the response to all commands and inquiries as DON'T/WON'T).
I heard "CRC" mentioned in some forum as being a problem

Should CRC be turned off?

I tried both. I also tried Y modem and that worked as well. I have absolutely NO issues whatsoever uploading or downloading that file with any computer setup, baud rate, or protocol as long as translation is off.
Okay, just to make sure we are both on the same page, define translation for me (just to make sure I don't have it

Also, I believe BikerBob uses a UDS10 with an Atari ST computer.

Could you try here and see if you have any problems? Thanks.
Translation OFF means that when you call with the WiModem232 you have Telnet translation OFF (AT*T0).

I call your BBS using this:


This tells the WiModem232 that this call (only) will have Telnet translation off. Translation could be on or off, prior to this - it doesn't matter because this call will make sure it is off and then return Telnet translation to be whatever state it was set to (on or off) before the call was made.

I will try bikebobs BBS.
I created an account on Bob's BBS. I left him a note as well. Nice to see another BBS running on a WiModem232... we need to add that to the list.

Users browsing this thread: 2 Guest(s)