Trouble using ProTerm on Apple IIe enhanced
While I’ve been having a lot of fun using the WiModem232 to connect to various BBSs, one thing I’m trying to figure out is what happens when I use the hang up command in ProTerm. Once I disconnect from the BBS, I no longer see any of my typed input appear on screen. However, everything still seems to be working. For example, after disconnecting from a BBS, if I then type in ATI, the letters “ATI” don’t show up on screen like they did when I first started ProTerm (before having disconnected). However, even though nothing shows up when I type, when I hit the Return key, all the expected data then appears. In fact, all of the commands seem to be working, only none of them show up when I type. I can connect to another BBS using ATDT, but I just can’t see the command or the telnet address when I type it. But it does still connect. If I reboot, everything works fine again, until I again connect and then disconnect from a server and then I’m back to not being able to see anything when I type. Any ideas on what’s going on? Thanks!
That must be something to do with your modem driver setup. What modem are you selecting?
I’m using the suggested 2400 baud setup-

2400 baud - Generic 2400 baud driver
Init string - ATX1&C0&S1
Is this a legitimate copy of ProTerm 3.1 (not a crack)?

I don't see this with my Apple IIe or Laser128 using this modem driver and init string.

Are you using Apple-T to get in and out of terminal mode?
I am using Apple-T to get in and out of terminal mode.

The version of PT 3.1 that I’m using has been broken into two 140k disk images (boot and program) to work with my FloppyEmu.

So far it’s the only version that I’ve been able to use due to the limitation of the larger size of the official Intrec .dsk file and the limitations of the FloppyEmu not supporting those larger files with my controller card. Perhaps that’s the root cause of the issue.

If it is indeed a result of this version of the program, but I’m limited to only using this version, is there another solution? Physically unplugging and plugging the WiModem back in worked in getting the type to reappear. I tried using the AT*REBOOT command thinking it would do the same, but I got stuck with flashing red and blue lights. Is there another command that would do the same, or does it just take a while for the WiModem to actually reboot with the AT*REBOOT command?
Flashing blue and red means that the emergency flash jumper is being shorted!

Try typing ATZ instead of rebooting to see if the typing comes back.
That worked! Thank you!!

Out of curiosity, I would have thought that the emergency flash jumper being shorted would have had to be a hardware issue, and not caused by a command input. Does the jumper being shorted during a reboot command indicate something might be wrong with my WiModem hardware?

Thanks again for all the help!
The red/blue flashing means that the WiModem232's jumper pads are shorted by something. The reboot command is no different than removing and plugging in the power, so unless the pads are touching something metal, this should never happen.

Users browsing this thread: 1 Guest(s)