Apple IIc, ProTerm and WiModem232 disconnect problem
I picked up a WiModem232 last year, and have been using my ROM 255 IIc with ProTerm 3.1 and the WiModem232 to connect to BBSes for a while now with no problems.

The other day I upgraded my IIc to ROM4x so I could connect a SmartPort hard drive. Now when I disconnect from a BBS, the computer freezes up until I toggle power on the modem to reboot the WiModem. Same thing when I tried a ROM3 in the IIc. The modem also froze up when I tried sending a command to change the baud rate, but so far all the other commands seem to be working.  I can't just switch back to ROM255 to test it, as you have to make a minor alteration the the IIc motherboard (solder bridge a pad, cut another one, so it is not easily reversable.

Anyone have a similar experience or know of a solution, or know if  there some change in the later ROMs that mess with the modem connection?

I set up ProTerm 3.1 and the WiModem as per the instructions for the IIc on this forum.

I am guessing that whatever mod you are doing is probably disabling something that ProTerm might be expecting to see to make the modem work.
It is an official Apple mod. They provided updated ROM chips with instructions to cut a specific connection and solder bridge another one:

There are differences in how the serial port is handled between the original ROM255 and all later ROMs

But I don't know if that would cause the hangup problem.
The WiModem232 is just a serial device itself, exactly emulating a real modem. Since the problem appears to be with ProTerm, have you tried another terminal program?
You might also want to try AT&F to reset the settings to the defaults in case the DTR on hang-up is enabled.

Users browsing this thread: 1 Guest(s)