New User Issues on Win 10
Hi, I've attempted clean installs as administrator on three different PC's today, but constantly see the same issue - the PC does not recognize anything being plugged into the USB, and the SCP itself does not light the green LED next to the miniUSB - the red/green lights during booting seem okay.

Initially I see the ftd2xx.dll issue, but manage to resolve that by copying the file from USB to the SCP directory. (System32 / SysWOW64 do not seem to work).

Though it then runs, it complains that superdisk pro board not found...

I've read through the forums and tried the different recommendations - should I persevere with this as likely just the driver issue, or could the hardware be at fault?

Many thanks

If the green LED next to the USB connector is not lit then USB driver is not installed or not recognizing the board.  Do you hear the normal chime when plugging in the SCP board?   Have you tried a different USB cable?

MAKE SURE that you install the SCP software in Administrator mode.  The installer is TWO parts - the main software, and then the driver installation.  Make sure you are completing both parts.
Hi, yes I have tried 2 different cables, and no I do not hear any chime at all when plugging the board in - this is the same for all 3 different PCs. I installed as administrator, and it install the software, then the USB driver. 

I've no other PC left to try this on - I have tried uninstalling and re-installing, but not sure if that would be as good as a clean install?


Do you have any anti-virus programs running?
You could try downloading the driver package directly from FTDI's website and installing it:
Thanks, I have switched off anti-virus and reduced user account control to never notify, but install looks unchanged.
I have also tried the driver package from the site directly as advised above, but it still does not seem to work.

If I look under Device Manager I do not see any kind of USB serial device, or anything unknown in Other.

Also, plugging in and out does not result in any device connect/disconnect sounds from the PC.

Also, every time I re-install, ftd2xx.dll has to be manually copied to the SCP otherwise it errors...

A most curious conundrum...
Its working!

Just to let everyone know, out of desperation last night I ordered an Amazon Basics mini USB cable as the two I were using were ~10 years old.

I didn't hold out much hope to be honest, but as soon as I plugged it in I heard the Windows hardware detect beep, and when launching SCP it found the floppy disk drive.

Hard to believe, but worth checking everything, no matter how unlikely it seems.

Thanks for all your help!

Some USB cables have teeny tiny power leads, 28AWB~30AWG, which have too high a voltage drop when any substantial current is drawn. I've seen this cause problems with many USB devices.
The SuperCard Pro draws about 30mA of current, so it doesn’t need much!

Glad you got it working with a new cable!

Users browsing this thread: 1 Guest(s)