Cannot Connect to WiFi, No Router Located?
#1
I have a new WiModem that I'm unable to connect to WiFi for reasons that are not clear. It can see my SSID but it cannot successfully connect to it. I have a C64c with a new WiModem on one end and a Linksys router running OpenWRT (WPA2, force AES) on the remote end. No other devices are having difficulty connecting via wireless, the signal strength is quite strong and the router is a mere 3 feet away from my C64. 

When I type ati the modem gives me the following specs:

Firmware v2.94 08/15/18
300 baud
channel 11

When I type at*n I clearly see my SSID in the list and it contains only letters, numbers, and a hyphen. I have attempted to connect by name (at*ssid) and by number (at*nsN) without any luck. The modem will clearly attempt to connect and simply fail. My router logs seem to indicate a connection was attempted with the wrong password.

I have gone so far as to temporarily rename my SSID to cbm and set the required WiFi password to "password" and attempt to connect... still no luck. I re-seated the modem (with the power off, of course) etc., etc. On the WiFI router end I've ruled out a congested channel. I'm running out of ideas.

I'm using the most recent CCGMS terminal program and it's set to 300 baud. I've also tried it at 1200 baud, too without any luck.

In case it's somehow relevant, the following peripherals are attached to the C64:
  • WiModem (obviously)
  • Eazy Flash 3 (boots into JiffyDOS)
  • SD2IEC (contains CCGMS terminal program on SD card)
  • JPX64 (allows Sega game pads to be safely connected to the C64's joystick ports; port 1 has a 1351 mouse pass-through port -- all populated).
  • Modern heavy duty power supply.
What else should I try?
Reply
#2
MAKE SURE you are using a terminal program in ANSCII or ASCII only mode.  If you are using a CBM graphics mode you can not enter the password with the correct case (upper and lower will be inverted).  I would recommend using CCGMS and pressing F8 to change to ANSCI mode.  At that point you can enter the ssid name and password correctly.  You will no if you are in the proper mode because when you do a ATI the text will come out looking correct, with the upper/lower case being correct (first letter capitalized).

Each WiModem is connected to my router (which is AES protected) for programming it, so every one of them is hand tested prior to shipping.
Reply
#3
(09-16-2018, 09:02 AM)admin Wrote: MAKE SURE you are using a terminal program in ANSCII or ASCII only mode.  If you are using a CBM graphics mode you can not enter the password with the correct case (upper and lower will be inverted).  I would recommend using CCGMS and pressing F8 to change to ANSCI mode.  At that point you can enter the ssid name and password correctly.  You will no if you are in the proper mode because when you do a ATI the text will come out looking correct, with the upper/lower case being correct (first letter capitalized).

Each WiModem is connected to my router (which is AES protected) for programming it, so every one of them is hand tested prior to shipping.

Hello,

I have a weird issue with my wimodem, I can only connect to my iphone8 in tethering mode.
So far I have tried an old TP link, several airport express, the eero one, with different setings wpa,wpa2,aes,tkip, b,g,n,a,ac, password all in uppercase, lowercase, just numbers still no luck
The wi-fi access point were close, not so close, between 39, 60db. This was the case with firmware 3.40 and also after an update to 3.41.
I'm using ccgms anscii with 300bauds. ati works fine, info msg show the case.
Going through the posts, I understand the devices are thoughtfully tested and should either works or not but not randomly.
I have then rested again with all the different at*ns and at*ssid command, doesn't put space on ssid nor passwords. 

I running out of options for today, so puzzling only my iphonecan make it!

Thanks for any new hints to try out  Wink
Reply
#4
Well, if it works with your iPhone then the WiModem itself works.  You need to check your router’s firewall settings.  The iPhone tethering does not have a firewall or any type of filtering.  If you disable the encryption and it still does not find the router then the router is denying it because of some setting, like a firewall, IP filter, etc.
Reply
#5
(04-21-2021, 03:36 PM)admin Wrote: Well, if it works with your iPhone then the WiModem itself works.  You need to check your router’s firewall settings.  The iPhone tethering does not have a firewall or any type of filtering.  If you disable the encryption and it still does not find the router then the router is denying it because of some setting, like a firewall, IP filter, etc.

Hello,

thanks I completly forgot about my pi-hole. Looking to the query list I saw this entry:


Code:
raw.githubusercontent.com/StevenBlack/hosts/master/hosts: modem.pw


I added the domain to the Whitlist and now it works. Cool
br
nico
Reply
#6
Oh yeah, I forgot about that. I had to add an exclusion for my PiHole as well!
Reply




Users browsing this thread: 1 Guest(s)