Cannot update to 1.20
When I launch the program (in admin mode) I get the prompt to update. I click OK. It reports as ok, relaunches, and continues to prompt me to update. This just repeats until I hit cancel.
Run the program in Administrator mode. Right-click the icon and select "Run As Administrator".
I am already Smile
Are you running an anti-virus program? I am running Windows XP, Windows Vista, and Windows 8.1, all of which auto-update just fine.

SCP stores the new version to the Program Files or (x86 version with a 64 bit machine), so you MUST be running in Administrator mode for this to work. What you describe is exactly what happens when you are running in user mode, or an anti-virus program is preventing access to the Program Files folder.
Did you actually right-click the icon and select "Run As Administrator", or just assumed you were already in Administrator mode? I have had several people just assume they were in Administrator mode because the login account was "admin" or "administrator", which was actually not the Administrator account! Right-clicking and selecting "run as administrator" worked for them.
No, I modified the properties of the shortcut to always prompt me for the admin mode. I get the prompt, and accept the credentials elevation.

I tried disabling my anti-virus but that made no difference.

I launched Fiddler to see if I could detect what the program was doing with HTTP and it seems to be getting the 1.20 version response when trying to GET the DAT file. It then downloads the latest exe (which is named scp_update.exe) but it never appears in the program folder.

I was able to just download that file and manually put it in there, getting the latest version. But I still want to squash this weird issue. Can you give me a link to the version prior to 1.09 and I'll download that and try to update from that exe to see if it works?
There is no link. I don't keep previous versions on the server to avoid confusion. The only time a write to the program files directory is not allowed is while NOT in Administrator mode. For some reason, your system is not elevating to Administrator mode. You might try right-clicking on the icon and selecting "Run As Administrator".
I think I figured it out. I think I updated by accident, not realizing I did (probably just hitting enter on the prompt real fast) but not knowing that, and never having updated before, I redownloaded and installed the program over the old one. This prompts me to update, as it should. However, there was already a SCP_1.09.exe file in the directory.

It seems the update logic does this:

1. rename scp.exe to scp_<version>.exe
2. download download scp_update.exe
3. rename scp_update.exe to scp.exe

Since step 1 fails because there already was an scp_<version>.exe file there, step 3 then fails because scp.exe is still sitting in the directory.

If I delete scp_<version>.exe from the folder and try the auto update, it works. Smile
Actually the download occurs first, then the rename of SCP.exe to the version number, then the rename of scp_update.exe to SCP.exe occurs. I will look at the code. I am guessing when the rename fails (because it is already there) the error message occurs. I will fix that.

Thanks for the details!

Users browsing this thread: 2 Guest(s)