New WiMondem user with a few questions
Hi there,

I purchased a WiModem recently for my C128 and have been trying to get it set up properly for various services but have been having a few issues. Let me apologize up front for the verbosity of this posit; I want to try and include as much info as I can.

So let me start with what works. I had no problems at all connecting to my WiFi, setting up some phonebook entries, and adding a spoof entry for QLink. I can connect to my local Linux machine via telnet at 9600 baud just fine with at*t1 enabled, attach to my screen session and check mail, IRC, etc. no problems.

What I can't do, however, is download any files. I have tried xmodem and zmodem, 300, 1200, 2400, and 9600 baud in both DesTerm128 v3 as well as CCGMSTERM in 64 mode. Whenever I try to download a file, the terminal sees the transfer start correctly and goes into download mode, but then it's just gets errors and writes no data to disk. Eventually the transfer fails and my screen begins filling up with garbage so I have to power cycle.

At this point I should mention that the C128 has JiffyDos and is using a pi1541 and an sd2iec. I have a 1571 but it is not powered on for these tests. I have not cut the trace for UP9600.

Other issues, in no particular order:

- I can connect to QLink (1200 baud, AT&C0, using a spoofed phonebook entry) but it just sits there drawing + symbols forever. I am unable to access the server.

- I can log into NeoHabitat and the game proceeds to launch but after the disk finishes loading, it sits at a black screen playing the room change music forever. This may be a pi1541 issue, however.

- I can connect to v1541 using both 2400 mode and the 38400 driver (and ZeroPage's loader). I can login from the command line, access my directory, etc. However, if I attempt to load anything from Device 2, the screen turns blue and the transfer never completes. 

I have updated to the latest firmware as of 9/29/19. I have performed an at&f and an at*reboot. I have set at*t0 and 1. I have repeated all the tests on a breadbox 64 just in case something was wrong with my 128 but had the same result. The last thing I want to mention is that if I enable flow control, the entire machine locks up instantly, both on the 64 and the 128.

So, I'm hoping I'm missing something obvious here, but I've been banging my head on trying to get any of these services to work for weeks without success. Any help would be greatly appreciated!

Messages In This Thread
New WiMondem user with a few questions - by armitage - 07-30-2019, 05:30 PM

Users browsing this thread: 1 Guest(s)