The following warnings occurred:
Warning [2] Undefined property: MyLanguage::$archive_pages - Line: 2 - File: printthread.php(287) : eval()'d code PHP 8.1.27 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/printthread.php(287) : eval()'d code 2 errorHandler->error_callback
/printthread.php 287 eval
/printthread.php 117 printthread_multipage



CBMSTUFF FORUM
Won't connect with AT*SSID, but will with AT*NS - Printable Version

+- CBMSTUFF FORUM (https://www.cbmstuff.com/forum)
+-- Forum: CBMSTUFF PRODUCTS (https://www.cbmstuff.com/forum/forumdisplay.php?fid=1)
+--- Forum: WiModem (https://www.cbmstuff.com/forum/forumdisplay.php?fid=75)
+--- Thread: Won't connect with AT*SSID, but will with AT*NS (/showthread.php?tid=971)

Pages: 1 2


Won't connect with AT*SSID, but will with AT*NS - Bungo Pony - 02-11-2023

I own two WiModems. One connects directly to the C64 and one connects to a DB25. Both of these WiModems will not connect to my router using manual commands.

If I type AT*SSIDrouter,password it will not connect. However, if I type AT*NSx,password it connects fine. I'm trying to write software to interface with the WiModem, but I need to be able to enter the SSID manually which doesn't work on either WiModem.

The other WiModem uses a different command set. I have to type AT$SSID=router and AT$PASS=password, and then ATC1 to connect. It does not connect.

Anyone know what's going on?


RE: Won't connect with AT*SSID, but will with AT*NS - admin - 02-11-2023

It sounds like you are trying to enter text to the WiModem in a non-ASCII mode. If you are using CCGMS for the C64 make sure you are in ANSCII mode, not the typical graphics mode. Capitalization matters and being in the wrong text mode will prohibit you from entering the proper case that might be required. Also, make sure there are no space characters between SSID and the router name, or between the router name and comma (,) character.

The other modem you have is NOT a WiModem or WiModem232 - I don't ever use '$' in a command string.


RE: Won't connect with AT*SSID, but will with AT*NS - Bungo Pony - 02-11-2023

(02-11-2023, 03:39 PM)admin Wrote: It sounds like you are trying to enter text to the WiModem in a non-ASCII mode.  If you are using CCGMS for the C64 make sure you are in ANSCII mode, not the typical graphics mode.  Capitalization matters and being in the wrong text mode will prohibit you from entering the proper case that might be required.  Also, make sure there are no space characters between SSID and the router name, or between the router name and comma (,) character.

The other modem you have is NOT a WiModem or WiModem232 - I don't ever use '$' in a command string.

This isn't just a C64 issue. It has the exact same problem when I use a plain old dos PC. I have not been using any spaces in the command line.


RE: Won't connect with AT*SSID, but will with AT*NS - admin - 02-11-2023

Which wifi modem of mine do you have, the WiModem or the WiModem232? Clearly, one of the wifi modems is not mine so you are on your own with that one.


RE: Won't connect with AT*SSID, but will with AT*NS - Bungo Pony - 02-12-2023

(02-11-2023, 08:18 PM)admin Wrote: Which wifi modem of mine do you have, the WiModem or the WiModem232?  Clearly, one of the wifi modems is not mine so you are on your own with that one.


It'll be the WiModem232. I just tried it on a different router with a PC. Same problem.


RE: Won't connect with AT*SSID, but will with AT*NS - admin - 02-12-2023

Ok, what machine are you using the WiModem232 with? What terminal software? When the AT*NS,{passphrase} option works and the manual mode does not, it is 100% an issue with the text being entered correctly. If your router name or password has a space character or custom characters (non-alphabet characters or numbers), then you might not ever able to enter it manually.. you would have to use the AT*NS option, which is why I created it. Since the AT*NS,{passphrase} works then it means that issue is with the router name being entered.

Again, make sure there is no space character after AT*SSID, or before or after the comma (,) that separates the router name from the password. Examples:

AT*SSIDmyRouterName,myRouterPassword

Router name: myRouterName

AT*SSIDLinkSYS,testing123

Router name: LinkSYS

REMEMBER, router names and passwords are CASE SENSITIVE. If you are in a terminal where ALL caps are normal, you will need to use something that provides upper/lower case (correctly). Using a ASCII mode (instead of a ANSI mode) is required when setting up the SSID. This is the only time it is required.


RE: Won't connect with AT*SSID, but will with AT*NS - Bungo Pony - 02-17-2023

(02-12-2023, 09:13 PM)admin Wrote: Ok, what machine are you using the WiModem232 with?  What terminal software?  When the AT*NS,{passphrase} option works and the manual mode does not, it is 100% an issue with the text being entered correctly.  If your router name or password has a space character or custom characters (non-alphabet characters or numbers), then you might not ever able to enter it manually.. you would have to use the AT*NS option, which is why I created it.  Since the AT*NS,{passphrase} works then it means that issue is with the router name being entered.

Again, make sure there is no space character after AT*SSID, or before or after the comma (,) that separates the router name from the password.  Examples:

AT*SSIDmyRouterName,myRouterPassword

Router name: myRouterName

AT*SSIDLinkSYS,testing123

Router name: LinkSYS

REMEMBER, router names and passwords are CASE SENSITIVE. If you are in a terminal where ALL caps are normal, you will need to use something that provides upper/lower case (correctly).  Using a ASCII mode (instead of a ANSI mode) is required when setting up the SSID.  This is the only time it is required.

My router SSIDs are all lower case and have no strange characters in them. They're plain words. One is a 4 character word and one is a five character word. I've used Telix on the PC to try and work with both of them to no avail. That option just doesn't work.

I'll try and get a pic up of it not working when I get a chance.


RE: Won't connect with AT*SSID, but will with AT*NS - admin - 02-17-2023

Again, what machine are you using and what terminal program? It could be that the terminal emulation mode you are in (VT52, VT100, ANSI, etc.) is causing the characters to be inverted when being sent. This would swap upper/lower case.


RE: Won't connect with AT*SSID, but will with AT*NS - Bungo Pony - 03-01-2023

(02-17-2023, 05:53 PM)admin Wrote: Again, what machine are you using and what terminal program?  It could be that the terminal emulation mode you are in (VT52, VT100, ANSI, etc.) is causing the characters to be inverted when being sent.  This would swap upper/lower case.

Machine and program are irrelevant. Here's a picture of it not working. If you really must know, I'm using a program I wrote called "Crapterm" on the C64. I wrote it solely for testing. The same thing happens with Telix on a PC.

image


RE: Won't connect with AT*SSID, but will with AT*NS - admin - 03-01-2023

You stated you have a WiModem232, not a WiModem. What you show is a C64 screen with the WiModem's display. Whatever you are using for a terminal program, it is in a PETSCII mode instead of an ASCII mode. How can I tell?... the character case is reversed (upper and lower case characters are backwards). An ASCII mode is *required* while entering the router's name and password... no exceptions.