The following warnings occurred:
Warning [2] Undefined property: MyLanguage::$archive_pages - Line: 2 - File: printthread.php(287) : eval()'d code PHP 8.1.29 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/printthread.php(287) : eval()'d code 2 errorHandler->error_callback
/printthread.php 287 eval
/printthread.php 117 printthread_multipage



CBMSTUFF FORUM
Downloading problems with WiModem 232 and a UDS-10 - Printable Version

+- CBMSTUFF FORUM (https://www.cbmstuff.com/forum)
+-- Forum: CBMSTUFF PRODUCTS (https://www.cbmstuff.com/forum/forumdisplay.php?fid=1)
+--- Forum: WiModem232 / WiModem232 Pro (https://www.cbmstuff.com/forum/forumdisplay.php?fid=79)
+--- Thread: Downloading problems with WiModem 232 and a UDS-10 (/showthread.php?tid=841)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16


RE: Downloading problems with WiModem 232 and a UDS-10 - admin - 11-07-2022

The change was made to the buffer handling (the buffer offset was only a byte wide instead of being a word wide), and that affects Zmodem as well as any other fast protocol (or even transfer) that sends more than 256 bytes. Glad to see it is working for you as well.

You will ALWAYS want to have hardware handshaking enabled (AT&K1). I probably should make this the default setting.

I have my buffer limit set to 4096. Anything over 1024 didn't seem to make much difference, but there was some. 512 seems to be about the minimum you should use for anything higher than 9600 baud which is why I bumped the default to 1024.

You need to send a ATH1 command to enable the OFF HOOK mode. Once you do that, the OFF HOOK message string will appear and the modem will never answer. Put it back on hook with ATH0. You will know right away if you don't have ATH1 enabled because the display screen will show OFF HOOK for the SSID, and the auto-answer flashing of the LED is disabled. You never know that someone has tried calling.

AT*HELP! has the new command (AT*OFFHOOK=), but it is not in the normal AT*HELP because the text is wider than the spacing that is made for each column of entries (designed for a 40 column display).


RE: Downloading problems with WiModem 232 and a UDS-10 - DarkLord - 11-08-2022

Got it! I had entered the OFFHOOK command to the WiModem232
while in a comms program (TAZ), then saved with AT&W but this had
no effect.

The software I use, BBS Express! ST uses the F10 key to exit from the
program. It also executes a file called "F10.MDM", which is a modem
file. Express actually has 3, BOOTUP.MDM, RESET.MDM, and F10.MDM.

I started out with "ATH1" in the F10.MDM file but this did nothing but
what I mentioned earlier - blinking cursor in SyncTerm when connecting
but nothing else.

Using "ATH1" followed by "AT*OFFHOOK=Testing..." from TAZ (again, a
comms program for the ST) set the WiModem232 successfully so that when
I connected it displayed the "Testing..." message.

So...I put that in my F10.MDM file:

ATH1
AT*OFFHOOK=Testing...

and it works. I can be running my BBS, DarkForce!, exit with the F10 key, which
executes the F10.MDM file and then when I call in it issues the "Testing..." message
so we're good!

Thanks Jim! Smile


RE: Downloading problems with WiModem 232 and a UDS-10 - admin - 11-09-2022

You can NOT stack ATHx with any other command. The ATH1 is what matters here. The message is stored permanently so you can set it permanently by setting however you want then save it with AT&W. ATH0 or ATH1 are not a stored setting so you will have to issue ATH1 (by itself) to invoke this feature. Most BBS programs have a "off hook" or "maintenance mode" setting that would normally send ATH1. Back in the day, a caller would just get a busy signal until the BBS was put back online.

Glad you got this sorted out!


RE: Downloading problems with WiModem 232 and a UDS-10 - DarkLord - 11-09-2022

Hmm, interesting. I'm not sure what's going on with it here,
or what I might be doing wrong.

I did an AT*OFFHOOK="message" and saved it with AT&W.

If I just put "ATH1" in my F10.MDM then execute it and
leave BBS Express! ST, it will only give a blinking cursor
in SyncTerm (or any other comms software) when I call.

It's only if I add the second line including the AT*OFFHOOK
command that it actually displays the message.

This is probably a BBS Express! ST thing, but it's working
so I'm gonna roll with it... Smile


RE: Downloading problems with WiModem 232 and a UDS-10 - admin - 11-09-2022

Are you including a {RETURN} after the ATH1?

Because you are including the 2nd line, the first line would have a return after ATH1 at that point.

You can test the functionality by loading a terminal program and just typing ATH1 {RETURN}. The OLED screen will show "OFF HOOK" where the SSID is shown when this is enabled.


RE: Downloading problems with WiModem 232 and a UDS-10 - DarkLord - 11-09-2022

Okay, just to be crystal clear, is there supposed to be a {return}
after the ATH1 command or not?

Thanks.


RE: Downloading problems with WiModem 232 and a UDS-10 - admin - 11-10-2022

Yes! EVERY single command that can not be stacked together MUST have a {RETURN} immediately following the command in order for the command to be sent to the WiModem232.

Even if you do stack commands together (for those commands that can be), you still need a {RETURN} at the end of the command string in order to send that to the WiModem232. Without the {RETURN} (which means you are pressing the RETURN/ENTER key on your keyboard) there is no way to enter a command. In the case of a script file, you need to make sure that a RETURN (CR) and/or LINEFEED (LF) is being sent after the command.

Many programs will use the C coding's fprint() type of data structure, where you can use \r as {RETURN}. So, ATH1\r on many systems will send ATH1 and {RETURN}. You might consult the BBS manual, but it seems to me that you can just enter a return after the ATH1 to drop it to the next line in your text editor and that should work. That is why it works with ATH1 followed by the AT*OFFHOOK= command. I would be willing to bet that unless you have a {RETURN} after the AT*OFFHOOK= string that the AT*OFFHOOK= is not actually changing anything and it would be using whatever was saved previously. You ALWAYS need a {RETURN} in order to have anything you want sent to the WiModem accepted.


RE: Downloading problems with WiModem 232 and a UDS-10 - DarkLord - 11-10-2022

Okay, this is really strange! (but you've come to expect that from me and my setup, right?) Smile

In between messages, I tried "ATH1" with a {return} and without at the end of the line in my
F10.MDM file. Neither worked. This was after making sure that I had used the AT*OFFHOOK
command to enter a message and using AT&W to save everything.

As soon as I added "AT*OFFHOOK="message", it works.

I tried it on 2 different WiModem232's with the same result. I also tried another experiment. On
both WiModem232's, I used a message with only the beginning letter capitalized. In the F10.MDM
file, I capitalized the first letter of every word.

When I tried it like that, the message that was displayed with both modems was the one with all
caps from the F10.MDM file.

I did take note of the LED on both and when the ATH1 is issued, both do say offhook.

I dunno Jim. But it is working, even if not in the way that it's supposed to so I'm gonna run with
it. Smile

Thanks!


RE: Downloading problems with WiModem 232 and a UDS-10 - admin - 11-10-2022

Can you send me the F10.MDM file to look at? Maybe you can view the file in a hex editor or something where you can see ALL of the characters.


RE: Downloading problems with WiModem 232 and a UDS-10 - DarkLord - 11-10-2022

I can try...

Okay, I zipped them up because that's the only way it would allow me to send it.

They are:

F10.MDM - This is the working version, with 2 lines and both commands.

F10.MD2 - This is ATH1, with a {return}.

F10.MD3 - This is ATH1, with no {return}.


.zip   F10.zip (Size: 394 bytes / Downloads: 1)

Thanks.