CBMSTUFF FORUM
Problem with Windows XP - Printable Version

+- CBMSTUFF FORUM (https://www.cbmstuff.com/forum)
+-- Forum: CBMSTUFF PRODUCTS (https://www.cbmstuff.com/forum/forumdisplay.php?fid=1)
+--- Forum: SuperCard Pro (https://www.cbmstuff.com/forum/forumdisplay.php?fid=3)
+---- Forum: Installation and setup (https://www.cbmstuff.com/forum/forumdisplay.php?fid=5)
+---- Thread: Problem with Windows XP (/showthread.php?tid=748)

Pages: 1 2


Problem with Windows XP - Callmejack - 08-29-2020

I have several problems under windows XP. The machine I used as a bridge computer was running Windows XP and I had no problem running SCP. I recently had a hard disk failure and decided to setup a new (faster) machine, with a fresh Windows XP sp3 setup. 
  • I first tried to install the latest version 2.2 of SCP which didn't work (said that it was not a valid win32 application. 
  • I then tried with an older version that I had (1.95) and it installed fine (I did install the software in administrator account and running it as admin, driver signing verification was disabled). 
  • I registered msstdfmt.dll and rebooted  
  • After rebooting I then plugged the card but there was an error during drivers installation "cannot start this hardware USB Serial converter, the driver may be corrupted or missing. On the device manager there's a yellow icon besides USB serial converter confirming that the device driver is not properly setup (same error 39).
  • When I start SPC (running as admin), it says there is no board.
The strange thing is that it's been working on my older machine before, this PC had SCP version 1.95, but it was upgraded from an older release (which I can't find). What could be the issue ?


RE: Problem with Windows XP - admin - 08-30-2020

The latest installer works on an XP machine. I just actually used it for installing the SCP software a Dell D610 laptop running Windows XP SP3 a few days ago. I didn't have a problem with any step. The latest installer actually copies the x86 (32 bit) application and registers the DLL automatically.

You could try going to the USB chip maker's website and download their latest installer. I use a sub-set of that installer.

https://www.ftdichip.com/Drivers/D2XX.htm

I am sure you will need the 2.12.28 (32 bit) version.


RE: Problem with Windows XP - Callmejack - 08-30-2020

I tried on 3 different installations of windows XP SP3 (2 as VMWare virtual machines and one physical). They all fail with the same error. I enclosed a print screen. 
I noticed that you're using Inno Setup to create your install package and I found a thread that says that version 6 and later are not compatible with Windows XP
https://stackoverflow.com/questions/60913365/inno-setup-installer-on-windows-xp-gives-not-a-valid-win32-application
Could this be the reason for this problem ?

I updated the ftdi driver but it didn't solve te problem.


RE: Problem with Windows XP - admin - 08-31-2020

Yep, this is very likely the issue.  I used an older version of the SCP installer I had on a thumb drive and just did the auto-update feature to update to the latest version on my Dell D610 Windows XP system.

I will look at making a new installer with Inno 5.x.


RE: Problem with Windows XP - Callmejack - 08-31-2020

Was Version 1.95 of the installer also created with version 6 of Inno ? If yes this could also explain the second problem I have with the ftdi driver not recognized. It could be that some keys in the registry were not properly created and therefore I find myself at the same situation as I connect the board without first installing the scp program.


RE: Problem with Windows XP - admin - 08-31-2020

I switched to the v6.x Inno setup when going to v2.0 (I think). There should be nothing ever written into the registry by my software or the FTDI software.


RE: Problem with Windows XP - admin - 09-01-2020

Try this one:  https://www.cbmstuff.com/temp/xpsetup.exe

So... it turns out that the problem is the FTDI drivers. They are no longer compatible with Windows XP!

You need to use an older version with Windows XP:

https://www.ftdichip.com/Drivers/CDM/CDM%202.08.24%20WHQL%20Certified.zip

I just setup a new Windows XP laptop as a test and everything works fine once I install this version of the drivers.  You MAY need to delete all of the previous drivers using their FTClean program:

http://www.ftdichip.com/Resources/Utilities/FTClean.zip


RE: Problem with Windows XP - Callmejack - 09-01-2020

Works great ! Thanks for you excellent support !


RE: Problem with Windows XP - admin - 09-01-2020

You're welcome! It's a nightmare trying to keep up with all of the legacy systems!


RE: Problem with Windows XP - DeltaDon - 11-06-2020

I'd like to thank both Admin and Callmejack for solving the problem of a new installation on a XP computer. Not every one is willing to support retro stuff. I have been using a Clevo D470W laptop running XP, now both well past their prime, as a workshop computer for programming chips with a TL866A programmer and also storing driver software for laptop computers I'm repairing. I just added a SCP to the Clevo successfully (I hope) with the XP install plus .dll's posted above. I'm just about to test the installation on a couple of Shugart SA300 drives. Then will know if I followed directions correctly or not. No error messages so far. After that, my next project is to complete a 34 pin to 26 pin laptop mylar cable adapter board so I can test some laptop floppy drives. I owned a laptop repair business some years ago and have stacks of spare drives I want to test and sell as working devices. Also, I want to test of a couple of 8" drives including one that had the magic smoke come out of a tantalum cap (now replaced) near the drive's power plug when I first powered it up. Some of these are for soon to be restored S-100 computers I've owned for decades.