The following warnings occurred:
Warning [2] Undefined property: MyLanguage::$archive_pages - Line: 2 - File: printthread.php(287) : eval()'d code PHP 8.1.29 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/printthread.php(287) : eval()'d code 2 errorHandler->error_callback
/printthread.php 287 eval
/printthread.php 117 printthread_multipage

Can't duplicate any disk - Printable Version

+--- Forum: SuperCard Pro (
+---- Forum: Hardware (
+---- Thread: Can't duplicate any disk (/showthread.php?tid=475)

Pages: 1 2 3 4

Can't duplicate any disk - Pitou - 02-12-2018


I just received my supercard pro and was not able to duplicate any disk so far.

Here is my setup:

- HP Pavilion Laptop
- Windows 10
- SCP hardware version 1.1 and firmware 1.2
- SCP software 1.94
- Tried 2 different ribbon cable.
- All drive were powered by external PS. Tried 2 different Power supply.
- Tried 3 different PC 1.44 floppy drives

  - Panasonic JU256A798P
  - ALPS DF354HD22F
  - Not sure about the 3rd one, please see photo

I'm trying to copy a standard Amiga diskette for now.

I looked at the Flux display, but not sure if it makes sense or if it looks good!

What additionnal info would you need to help me with the issue?

Thank you.


RE: Can't duplicate any disk - admin - 02-12-2018

For commercial disks, use the INDEX mode. For non-commercial disks (your own disk) use SPLICE mode with 2 revs. If you are trying to create image files for emulation (WinUAE), use the FLUX to .adf conversion option.

Try the media integrity test found in the Utilities menu to verify that the disks you are trying to use are any good. It's very common to see failures on 3.5" disks because of time, especially starting at track 72 (through 79).

RE: Can't duplicate any disk - Pitou - 02-12-2018

I tried the media integrity check, but it fails on all tracks and all heads starting from track 0.

Those diskettes work fine formatted in an Amiga.


RE: Can't duplicate any disk - Pitou - 02-12-2018

Here is a screenshot of the track 0 head 0 reading from a standard disk that works fine in my Amiga. (read from the Panasonic drive)

If that could help.


RE: Can't duplicate any disk - admin - 02-12-2018

You have a drive problem.  See the wavy signals on each line?  Those should be flat.  Typically this means the drive motor speed is bad.  This can be caused by bad power to the drive, bad drive motor, or a disk that is really dirty and loud when spinning.  How are you powering the drive?  If it is from the SuperCard Pro directly, then your USB port is likely not one that can handle more than 90mA of current.  You need at least 500mA of current, which is common with USB hubs and motherboards with internal hubs.

RE: Can't duplicate any disk - Pitou - 02-13-2018

Like I mentioned in my 1st post the drives are powered from an external PSU. I even tried 2 different PSU.

I just captured 2 screenshots of track 0 from the other 2 floppy drives I have.

Please take a look at them.

It's strange that those drives work fine in a PC though.

The disk is not loud when it spins. This disk work fine in an Amiga.

I also did a screenshot of the RPM.

Thanks for your help!


RE: Can't duplicate any disk - Pitou - 02-13-2018

I just found out the model of the "noname" drive. It's a Fujitsu.


RE: Can't duplicate any disk - admin - 02-13-2018

The other two floppies look ok, so perhaps that 1st disk is not rotating smoothly.

Run the media integrity test on a disk, and then go look at the flux with the editor/analyzer (like you have with the other images you posted). You should see a single, narrow line. If you don't then the integrity test will definitely fail. It's possible that you can copy a disk with a disk that fails, but it won't be optimal. What disk are you trying to copy?

RE: Can't duplicate any disk - Pitou - 02-14-2018

I'm trying to duplicate Workbench 1.3.

I made a lot of tests and made some great progress.

I can read almost any disk and save them into a .scp image and it works fine in WinUAE.

Now if I write back the .scp image to a real disk, that's where I have some issues. The real disk doesn't boot in a real Amiga and if I read again the disk I just wrote, then the .scp image doesn't boot as well in WinUAE.

In summary, I have a problem with write related to the drive. The same diskette writen with a real Amiga boots fine.

Now I have 2 questions:

1- Is there a way to fix the write in a floppy drive?
2- Regarding the Flux data image, why sometime I see "gap" or "blank" in the blue line?



RE: Can't duplicate any disk - admin - 02-15-2018

You have to duplicate non-INDEX'd disk using SPLICE mode (2 revs is all I use).

You could always use the HxC Floppy Drive Emulator software to read the .scp or .adf image and have it create a .scp image.  That process will rotate the tracks so that they start on the index pulse.  You can then load the .scp image into the copier and click the OVERRIDE button and set the mode to INDEX and proceed to make the disk.

The gaps in the flux is normal.  There are 3 different bitcell times that make up the encoding for the track.

What disk is that picture of?  That's definitely not the disk integrity test result.  There would be a single blue line about 3/4 up the display.  Trying doing a disk integrity test and when it errors out, click on IGNORE and let it do a few tracks, and then look at the results.  Whatever the data is, it has issues.  You shouldn't see random dots anywhere like.  You are cleaning the disk drive heads frequently, correct?