CBMSTUFF FORUM
CommodoreServer @38400 Baud - Printable Version

+- CBMSTUFF FORUM (https://www.cbmstuff.com/forum)
+-- Forum: CBMSTUFF PRODUCTS (https://www.cbmstuff.com/forum/forumdisplay.php?fid=1)
+--- Forum: WiModem (https://www.cbmstuff.com/forum/forumdisplay.php?fid=75)
+---- Forum: Usage (https://www.cbmstuff.com/forum/forumdisplay.php?fid=77)
+---- Thread: CommodoreServer @38400 Baud (/showthread.php?tid=361)

Pages: 1 2


CommodoreServer @38400 Baud - fuzzybad - 02-11-2017

Hello, hope you don't mind me starting a new CommodoreServer thread.  That one seems to be more general information.

I'm able to connect @2400 baud with no problems, it works well.  Now I'm trying to connect using the 38400 baud driver, and need a little help getting it fully working.

Here's what I'm doing:

1) Go into terminal
2) Execute commands:
AT&K1
AT*R0
AT*C0
AT*B38400
3) Exit terminal via soft reset
4) Load V-1541 38400 (and execute)
5) Execute 'connect' program which executes PRINT#2,"ATDTCOMMODORESERVER.COM:1541"

At this point the WiModem shows "connected" on LED panel.  I can execute commands to device #2, for example:  LOAD"$",2
However, the output appears corrupted.  For the above command, the first part of the directory listing is missing, then some junk characters, then finally the end of the listing is displayed normally.  

Can anyone please help?  I feel like I'm really close to getting this working.  I've tried using different settings for RTS/CTS/DCD and none resolve the issue.

Thanks!


RE: CommodoreServer @38400 Baud - admin - 02-11-2017

That is the correct inverted (normal actually) handshaking.

It seems that 38400 is working, at least partially because you are changing the baud rate and then issuing the connect command (which is connecting). I usually connect at 2400 baud and then switch to 38400, but it doesn't matter which order you do things in. I have not tried this since I switched to the later ESP8266 libraries, so I need to check that to see if the newer libraries are causing a problem.


RE: CommodoreServer @38400 Baud - fuzzybad - 02-11-2017

(02-11-2017, 05:29 PM)admin Wrote: That is the correct inverted (normal actually) handshaking.

It seems that 38400 is working, at least partially because you are changing the baud rate and then issuing the connect command (which is connecting).  I usually connect at 2400 baud and then switch to 38400, but it doesn't matter which order you do things in.   I have not tried this since I switched to the later ESP8266 libraries, so I need to check that to see if the newer libraries are causing a problem.

It's definitely partially working.  This was testing on an NTSC 64C; let me try with a few different models and report back.  It sounds like I am using the correct settings, so that is encouraging.


Thanks!
Jess


RE: CommodoreServer @38400 Baud - fuzzybad - 02-13-2017

Update on this issue; I've tried 3 different C64s (NTSC 64C, NTSC breadbin 64, and a PAL 64C) with the 38400 CommodoreServer driver and they all behave the same way. 

Here's a screenshot showing the typical result of CS 38400 baud driver:


[Image: foDkxAt.jpg]


Again, the 2400 baud driver works fine.  Has anyone had success with the 38400 baud driver?


RE: CommodoreServer @38400 Baud - Zeropage - 02-13-2017

I have the exact same problem.

I wrote  a little C program to chain all the steps together so that I could change the settings quickly but its more or less the same with all combinations.

Code:
ser_open(&serialParams);
   
   // Enable serial
   ser_ioctl(1, NULL);
   get_wimodem_status();
   ser_put_str("at&k1");
   ser_read_str(2000);
   ser_put_str("at*r0");
   ser_read_str(2000);
   ser_put_str("at*c0");
   ser_read_str(2000);
   ser_put_str("at*d0");
   ser_read_str(2000);
   //ser_put_str("at&c1");
   //ser_read_str(2000);
   ser_put_str("at*b38400");
   ser_unload();
   if (cbm_load ("v-1541.38k", getcurrentdevice (), NULL) == 0) {
      printf ("V-1541.38K failed to load\n");
      return 0;
   }
   else {
      printf ("V-1541.38K loaded ok\n");
      __asm__ ("jsr %w",0xc000);
   }
   __asm__ ("jsr 64738");



RE: CommodoreServer @38400 Baud - admin - 02-13-2017

Well, looks like the handshaking is not working on the C64 receive side.  I will re-produce this and then switch libraries to see if it's library related or due to something else in the code that changed at some point.


RE: CommodoreServer @38400 Baud - Zeropage - 03-10-2017

It looks like the 1.8 update has fixed this, thanks Jim


RE: CommodoreServer @38400 Baud - admin - 03-10-2017

Great, thanks for confirming it fixed it at 38400 baud.  I had not tested it yet, but I am not surprised due to the problem I had in the code that v1.8 corrected.

Hey, since you wrote a C program to init the modem, load the V-1541, and launch it, can you share the .prg file?  This would be handy for those that want to use 38400 baud with V-1541.

Thanks!


RE: CommodoreServer @38400 Baud - Zeropage - 03-11-2017

(03-10-2017, 05:48 PM)admin Wrote: Great, thanks for confirming it fixed it at 38400 baud.  I had not tested it yet, but I am not surprised due to the problem I had in the code that v1.8 corrected.

Hey, since you wrote a C program to init the modem, load the V-1541, and launch it, can you share the .prg file?  This would be handy for those that want to use 38400 baud with V-1541.

Thanks!

Sure, no problem . I have a reset program too.

I'll just tidy them up a bit.


RE: CommodoreServer @38400 Baud - admin - 03-11-2017

Reset is easy - just send ATZ and all of the settings are restored to the default. Smile