Full Version: BBSes with cursor navigation menus not working
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4
The reason Netrunner works well is because it's developed by the Mystic BBS developers. Tongue

Perhaps someone else with a retro DOS machine can chime in to confirm their experience accessing a Mystic BBS with lightbar menus and navigation as well.

On my Windows PC using ethernet, SyncTERM works just fine with ONYX and other Mystic based BBSes and render their lightbar menus and navigation, as does mTelnet, Qodem, etc. It just perplexes me why on my 486 DOS PC the WiModem232 seems to be working properly with every BBS just not Mystic ones and why the Zimodem works without issue on any BBS that i've "dialed" into on that machine.

It's pretty important to get things working properly with Mystic because it is one of the "big guns" within the community when it comes to running a BBS. It's right up there with Synchronet when it comes to the amount of sysops that use it. Smile
On my PC (Windows 10 Pro), SyncTERM definitely does not work. It does exactly like what you said where 3 failures of the lock occur when just pressing the cursor keys. Only NetRunner actually works.

I have thousands of customers using these, and this the first time I have had any reports of any particular site not working. I also have dozens of people using the WiModem and WiModem232 to run their BBS with. This is clearly not some wide-spread problem or I would have seen it many years ago (this product was started in 2015). I am not sure what to do to even figure out why you are having a problem because I can reproduce your exact problem without ever using my product. But, I am going to get a serial card for my desktop PC and try using NetRunner with that and the WiModem232 to see the result.
Well, that's the thing, it's not relegated to just a particular site, it happens to any Mystic based BBS that utilizes its lightbar menus and navigation. My intent was to report it as a potential bug, not to berate your product and I hope it wasn't taken that way as I'm not that kind of guy.

I may just look into getting a different Multi-I/O VLB card to see if it's a hardware incompatibility, I should do that anyway as the current one I'm using has a crappy 16450 UART, either that or just change out the motherboard entirely with another that has all the I/O onboard (I own several high-end 486 motherboards).  Big Grin
I could completely see if this was a Telnet issue because there are hundreds of Telnet commands, and I have zero interest in supporting anything more Telnet specific than I already have... but I did just add another Telnet function that probably needs to be there with v5.11 (released tonight). You might try it to see if there is any difference.
So, I am pretty sure that this is a Telnet issue. The very first thing that ONYX does is send a slew of Telnet control functions. I captured the output and I am going through the Telnet information to see what these do. It could be that the Zimodem stuff doesn't ignore incoming Telnet requests no mater what mode you are in, and it supports more functions than I do.. which is just 4 functions, all of which are to tell whatever is communicating that the WiModem refuses to do anything Telnet, so don't ask!
Tried the new firmware (v5.11) and the issue still exists.

Perhaps look for a telnet function possibly regarding keyboard usage, because what's happening regarding Mystic based BBSes is when cursor keys are pressed the WiModem232 is seeing it as an escape code as if the ESC key is being pressed.

For example on Blackflag BBS if you go to their ANSI Art Pack viewer and you press the cursor keys it straight up dumps you back to the main menu, this is only supposed to occur if the ESC key is pressed and the cursor keys are important for the menu navigation. That's also what is going on with the Onyx botchecker the WiModem232 is translating the cursor keys as if the ESC key is being pressed.
Don't forget that to use Telnet mode you need to enable it with the WiModem232. You can do that by using the AT*T1 to set the mode, or by placing that as part of the URL you are calling, ie. ATDT*T1,ONYXBBS.MYWIRE.ORG:2300

I am guessing this is a Telnet issue. The Zimodem info says that it always has Telnet mode enabled unless you specifically disable it using an S-register. From the instructions:

"ATS62=n : When n > 0, enables/disables telnet support in the ATD (Dial) command. Default is 1 (enabled)."

You can set ATS62=0 and try that to see if that stops working. The terminals that I tried that do fail on my PC do not support Telnet commands, so that would make sense why they fail and why NetRunner works.

After looking over the capture, I believe the issue is that the ONYX BBS is sending a request to know the terminal mode (along with several other commands), and I don't support any of them. The commands that are sent by ONYX BBS (before the intro screen where you select the terminal type) are: WILL ECHO, WILL SUPPRESS GA, DO TERMINAL TYPE, DO SEND LOCATION. I need to figure out a way to capture the port data with NetRunner so I can see the responses to these commands.
Hey Jim,

Just seeing if you've made any progress regarding this?  Smile
Did you try the Zimodem thing with Telnet disabled (as described in my last post)?

I have done nothing because I think this is a Telnet issue, and I can’t determine anything until my serial card arrives.

Yes I tried the Zimodem with telnet function completely disabled and all Mystic based BBSes that I tried still function properly.
Pages: 1 2 3 4