Full Version: RTS/CTS on Atari ST
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I've recently got one of these lovely devices and I'm having problems with hardware handshaking.

If I try to enabled it for a 19200 8n1 I just get error when using at&k1. I seem to get error no matter what AT&K setting I use. However it did work once and things were great I could connect to a lot more BBS's but when I wrote the settings AT&W it's never worked again.

I've tried it on an Atari STE 1048 (direct in the port) as well as a Mega STE (through a 9/24 pin cable) always the same result. Otherwise it works very well and that's awesome.

What "error" are you getting?
(02-20-2018, 08:38 PM)admin Wrote: [ -> ]What "error" are you getting?

oh sorry, specifically just getting ERROR in response to the command.



Huh? You must be typing it wrong, or you are not using my product. AT&K1{RETURN} has always been a valid command.
I agree it seems odd!

This is one of you devices as I just purchased it within the last 30 days and I'm definitely not typing it wrong.

Here are some pictures of the device and the results of the commands. If you need anything else please don't hesitate to ask.


It probably would not hurt to capture the results of the AT&V command to see what all your settings are.
Ah shoot! Yes that would have been good. I'll post that when I get home from work.
Try typing AT&K1 as shown (in capitals, not lower case).
Here's the output from AT&K1 and AT&K0. As well as AT&V

Ah... that helped!  Change AT&D2 to AT&D0.  You can't have RTS/CTS for flow control AND the DTR control at the same time.
Pages: 1 2