Full Version: UP9600
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4
I've been using the WiModem perfectly now for over a week set for 2400 baud and it's worked well. I decided to try the UP9600 mode this weekend and couldn't get it to work within Striketerm 2014 Final. Whenever I select UP9600 as the modem, the system hangs and never returns control. I have tried setting AT&K1 and AT*B 9600 before selecting the UP9600 modem and afterwards and it still hangs. 

If anyone has this working, how was this achieved. Did you use a different terminal program? 


-Eric (@duhproject)
I ran into the same problem with the Striketerm "final" version. I had to use a previous version of Striketerm for it to work. It could be that the final version changed the polarity of the RTS/CTS handshake. You can change polarities using the various AT commands. I did not investigate why it didn't work when I found that the previous version did.
Roger that -- I'll give that a go. Thank you!
(07-05-2016, 04:52 PM)duhproject Wrote: [ -> ]Roger that -- I'll give that a go. Thank you!

Were you able to get it going on UP9600 baud dUhprOject?
(07-17-2016, 09:59 PM)XxSwitchBladexX Wrote: [ -> ]
(07-05-2016, 04:52 PM)duhproject Wrote: [ -> ]Roger that -- I'll give that a go. Thank you!

Were you able to get it going on UP9600 baud dUhprOject?

I was able to get it working in Striketerm 2014 Final.  With the UP9600 driver I had to set it to 2400 baud in Striketerm, manually send AT*B9600 and then switch to 9600 baud in Striketerm and it worked like a charm.
Funny, I couldn't get Striketerm "final" to work, but it worked fine in the previous version. I just figured it was a quirk in the UP9600 driver that was on the terminal disk I have. Do you have a link to the version that you are using?
I don't know where I got the disk originally, but I made a copy of the one I am using: http://www.zoggins.net/striketerm.zip
If anyone else is having a problem with striketerm freezing when you try to change the modem to up9600, the solution is here :


just remove the wimodem, set the modem in striketerm, save the config and plug the wimodem back in(obviously AFTER powering off the machine).

Works a charm.

EDIT: Spoke too soon, it all seems to work fine until you connect to a server. Then I get a message saying "Soft wdt RESET" with a stack dump after it.

I dumped the memory out to get the stacktrace :

3FFF2D50: 00000000 00000000 3FFF1BA0 402027EE
3FFF2D60: 3FFF2E30 3FFF1B54 3FFF1A7C 40203A68
3FFF2D70: 00000000 00000000 00000000 3FFF1DB8
3FFF2D80: 3FFF1BA0 3FFF1BC4 00000001 40203682
000DA0: 00000000 000000 0000000 0000001 3FFF1DB8 FFF2D 3FFF2DD
That only occurs when the internet connection is hung. What version of the WiModem firmware are you using?
Pages: 1 2 3 4