Full Version: Writes not working
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
So I have two 5.25" drives - a 1.2m and a 360k.

Both can read disks just fine.

When I try to use either one to write disks, it doesn't work. Reading back the written disks shows most of the time just white noise for flux. Once in a while it will write a track that looks kinda like normal flux transitions.

The supercard pro disk archiver diagnostic media test always fails on every track on every disk in both drives.

Floppies are confirmed good, I can write them all day long on my atari 800 with 1050 drive.
Have you tried a different floppy drive cable (or position in the cable if you have a multi-position cable). What are you powering the drive with? Are you using a single drive or dual drives?

I use the media test program to confirm that all functions of the SuperCard Pro board work correctly, but it's always possible that the board has a problem. Do you have any other drives, including a 3.5" drive that you could use for testing?

Usually, this is problem is the cable or the drive jumpers. I just had a person have the same problem where the flux written back looked like snow over the original data, and it turned out to be the power supply AND the cable were both bad - talk about bad luck!
I have tried 2 different cables (one is a brand new cable), and I tried both cable positions. I tried both single and dual drives.

I have tried multiple ATX power supplies. a coolmax 700W and an antec 500W.

I don't have any 3.5" drive to test with at the moment.
Can you send me a dump made from an original disk, and also from the copy of that disk? I want to compare the two to see if there is anything valid actually being sent to the drive. Please send to data @ cbmstuff.com

What brand/model floppy drives are you using? We need to verify that the jumpers are correct.
sent email.

360k drive - Panasonic JU-455-7AAJ (aka Matsushita FMD01710B4)
jumpers: UA [DA] / MS [MM] / DS1 [DS2] DS3 DS4 MX / TM / RY - tried with both TM set and unset.

1.2m drive - IBM YD-380 Type 1711
jumpers: DS0 [DS1] DS2 DS3 HS [HM]
Both dumps have really distorted data and are fully of noise, with the writes being complete snow. What cable are you using?
I tried both a working cable taken from a working computer, and also a brand new cable purchased online: http://www.amazon.com/CablesOnline-Unive...B00FZ3IL80

take a look at the 2_read360k.scp. something strange happens around track 20.

it is worth noting a8rawconv has no problems converting these scp files to atari images, the initial reads. it of course can't make any sense of the snow that's been written by the scp.

i have a multimeter and an oscilloscope I can use to verify the SCP is working within correct parameters if you will tell me what to check.
I have never seen data come out of a drive like this before... instead of being normal flux data, it looks like a triangle wave. I guess as long as the bitcell times stay within the normal clocking window the data could be decoded... but I would say there is a definite problem with reads, and writes are not working at all. The write gate must be turning on, because you can see "something" that remotely looks like data. The data path is good or you would not get any data on the read side. When you use a8rawconv, are you using it to control the SCP board or converting an image that you dumped using SCP? a8rawconv will control the SCP directly if you want it to. Can you convert the exact same disk that you sent me the image of using a8rawconv?

Here is what you should probably do. Use the editor/analyzer to READ a track. Click on the Display Flux button. That will open the flux window and you can then see the changes to the flux data every time you READ a track. That data should look normal. Experiment with that to get use to seeing what flux data looks like, especially between different disks. Once you have done that, run the MEDIA test. You said it failed. Read the first failed track back in the analyzer and look at the flux data. You should see a perfectly straight line across the flux display. If you don't, or it's fuzzy then it's either the disk, drive or the cable.... or maybe even the density wrong. Have you tried switching the density with the pull-down menu?

I can certainly replace the SCP board - they have a lifetime warranty. I have had this same problem happen with two different people using 3.5" drives, and in both cases it was the drive (and one was the cable as well).
tried a 3.5" drive and another brand new cable. reads perfect. writes snow.

a8rawconv has no problem to convert the 1_read360k.scp and 1_read12m.scp to working ATR images.

i have tried:
3 drives (360k, 1.2m, 1.44m), 3 cables, 2 power supplies, 2 computers. all result in exactly the same -- reads fine but writes snow.

i am out of ideas Sad

i have an oscilloscope, i have a multimeter. what i can check for to verify the SCP is working correctly ?
Well, I can tell you that your reads are not normal by any means.  It's possible that if you ever plugged the ribbon cable in backwards that it killed Huey and/or Duey.  There was no way to prevent that from happening in the design, and still have bi-directional capability.

There is really nothing for you to check on the SCP board because you likely don't have replacement tools for fine pitch SMT parts.   Unfortunately, you need to return it and I will replace it.  I test every single board after programming them using a 3.5" drive and the media integrity test, so it definitely works when it leaves here.
Pages: 1 2 3