Full Version: Imaging problem?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I tried imaging a few Atari disks to see how things were working. I didn't get any errors creating the SCP but Phaeron's converter program fails to convert them to ATX. It complains that no sectors were found for all 40 tracks.

Here are the images:


I've tried two different drives with two different floppy cables with the same result.

Any thoughts?
I see the same thing with disks I tried to convert with Phareon's converter, but disks created from the images work just fine.

Have you tried making disks from the images and testing them?
(11-19-2014, 08:14 PM)admin Wrote: [ -> ]I see the same thing with disks I tried to convert with Phareon's converter, but disks created from the images work just fine.

Have you tried making disks from the images and testing them?

I just tried making a disk using a spare Atari floppy disk I had laying around with existing data. Interesting thing is that using SCP to write the image to disk seems to have no effect -- it still had the original data after the write operation. I even tried doing a disk erase from within SCP and the old data remains on the disk.
Try running the media integrity test. I do this for every board as part of testing it. This will test the board, cable, drive, and disk.

What disk drive are you using? Is the drive 0 or 1? What disk type are you selecting for imaging/copying?
I didn't see a "Disk Integrity Test" in SCP. Am I missing something?

I did see a "Media Test". I ran that against 3 different drives using 2 different floppy cables (one is the "twist" type and the other is a straight). The cable didn't make a difference in the outcome of the tests. Drive #1 is one that I used successfully with Kryoflux in the past.

Drive #1 (Teac FD-55GFR)
Failed media test immediately.

Drive #2 (Toshiba ND-0401GR)
Intermittent failures during media test. About midway though, started making a clacking noise as if the drive head was hitting something.

Drive #3 (brand new OEM Panasonic JU-475-5)
Intermittent failures during media test. Didn't do the clacking noise.

Since Drive #3 seemed to be the best candidate, I tried re-imaging a known good disk (Tumble Bugs) and wrote it to a blank. I got a disk that booted but the graphics were corrupted.
Updated on this: I tried SCP on a native Windows 7 machine (my other machine was Windows 8.1 in VMWare) and found that Drive #3 passed the media test without any errors. However, when imaging Tumble Bugs and writing the image to another disk, I still see the corrupted graphics issue.
I just looked at the disk image (Tumblebug) that you put in the Googledrive link above. I do see a bug in SCP software when using Atari 400/800 disk images in the analyzer. If you switch the disk type to be IBM360K, TRS-80, etc. then the image shows track/side correctly. So, I have something goofed up when it comes to plugging in the values for the Atari 400/800 disks. I will have to see if this problem also exists when writing disks. It's been a long time (probably March) since I last tested Atari 400/800 disks and a lot has changed since then. Have you tried making a copy of the disk (drive 0 to drive 0 or drive 1 to drive 1) instead of imaging the disk and then trying to write the image back? You could also set the disk type to be TRS-80 as a test (Atari 400/800, IBM360K, TRS-80, CP/M, etc. are all the same disk format).

Your Tumblebug disk or (more likely) the drive head is really dirty. The flux is pretty bad, so you should clean the drive head. You can look at the flux in the analyzer by loading the image and clicking on Flux Display. A new window will open showing the flux data. Change the disk type to IBM360K so that the track/head is correct while viewing the image. Otherwise (due to the bug I see), the disk image will show up as 80 tracks, instead of 40 tracks with two heads. Both sides of the disk are imaged with Atari 400/800 disks. I will look into this more today.