Apple IIe/IIc/IIgs setups
#1
This thread will describe how to setup the WiModem232 for use with Apple //e, Apple //c, and Apple //gs systems.

Apple //c & Laser 128

Cut the traces and add the solder bridges as shown in the manual - NOTE: NOT AN OPTION! (only applies to V1 WiModem232!  V2 requires NO changes)

ProTERM terminal program settings

Port type - Apple //c or Laser 128 (depending on your computer)
Modem cable - 5 pin din to DB25 cable.  This is a standard modem cable, NOT a NULL-modem cable!

Modem types:

300 baud - Apple 300 baud driver
Init string - ATX1&C0&S1

2400 baud - Generic 2400 baud driver
Init string - ATX1&C0&S1

9600 baud - Generic Fixed-Speed (RTS/CTS) driver
Init string - ATX1&C0&K1&S1


Apple //gs using built-in modem port

Cut the traces and add the solder bridges as shown in the manual - NOTE: NOT AN OPTION! (only applies to V1 WiModem232!  V2 requires NO changes)

ProTERM terminal program settings

Port type - Apple //gs Modem Port
Modem cable - Apple //c+, Apple //gs or Apple Mac 8 pin din to DB25 cable.  This is a standard modem cable, NOT a NULL-modem cable!

Modem types:

300 baud - Apple 300 baud driver
Init string - ATX1&C0&S1

2400 baud - Generic 2400 baud driver
Init string - ATX1&C0&S1

9600 baud - Generic Fixed-Speed (RTS/CTS) driver
Init string - ATX1&C0&K1&S1


Apple //gs with Super Serial Card

Cut the traces and add the solder bridges as shown in the manual - NOTE: NOT AN OPTION! (only applies to V1 WiModem232!  V2 requires NO changes)

Super Serial Card setup

You will need to set the dip switch settings correctly!  Please refer to the photos below for the proper setup.  These settings are being used by many people for different purposes besides the WiModem232 (like ADTPro) and they ARE the correct dip switch settings to use!  Also note that there is a 16 pin solid jumper block on the right side of the board that has a triangle (arrow) on it.  The arrow must be facing as shown in the picture (pointing towards "MODEM" that is printed on the circuit board).


ProTERM terminal program settings


Port type - Super Serial Card (select the slot your SSC is in - make sure your control panel setting is correct)
Modem cable - Direct connect using DB25 gender changer

Modem types:

300 baud - Apple 300 baud driver
Init string - ATX1&C0&S1

2400 baud - Generic 2400 baud driver
Init string - ATX1&C0&S1

9600 baud - Generic Fixed-Speed (RTS/CTS) driver
Init string - ATX1&C0&K1&S1

NOTE!  ProTERM will fail to initialize the modem until you have changed the DCD polarity with AT*D1.   Once the failure box pops up, select ONLINE to continue.  Go to terminal mode using Option-T.  Once in termal mode type AT*D1&C0&W (you should see an 'OK' response if successful).  That will change the DCD to be proper and save the settings.  From that point, restart ProTERM and the modem initialization will work correctly.



Apple //e with Super Serial Card

Same as //gs with Super Serial Card


Attached Files Thumbnail(s)
       
Reply
#2
Note: In the below examples {RETURN} means to press the RETURN (or ENTER) key.  Do not type {RETURN}!  You should probably make sure that you have all of the settings at the defaults using AT&F.  If you do this when not using a baud rate of 300, the baud rate is reset!  Make sure you reset the baud rate to whatever you were using after doing the AT&F command or you will end up saving the baud rate at 300 by accident when proceeding below!

The WiModem comes stock (and resets to) 300 baud.  So, in order to use 2400 or 9600 baud you need to change the baud rate within ProTERM and then switch to install to change the driver, and then save the new baud rate with AT&W.  So:

Run ProTERM and install the 300 baud driver and your port.

Once you have ProTERM's menu up, press Apple-T (or Option-T for the //gs) to go to terminal mode.  From there type:

AT*B2400 {RETURN}

You should see OK and then the modem will no longer respond because it is now at 2400 baud.  If you want to switch to 9600 baud just use 9600 instead of 2400.  Now, press Apple-T (or Option-T) again to get the menu back.  Select option O to set the online parameters.  Scroll the menu selection to the far right.  The last item in the right most column will be INSTALL.  Select that and then install the proper driver and port for the new baud rate.  Once this is done, again press Apple-T (or Option-T) to go terminal mode.  You should now be able to type ATI and see the info.  NOTE!  You may not see what you are typing!!  This is done deliberately by ProTERM (it turns off the auto-echo every time you come back from terminal mode).  You will want to turn on auto echo and save your baud rate by typing ATE1&W {RETURN}.  You can now use ProTERM at whatever baud rate you selected.
Reply
#3
(02-17-2018, 03:47 PM)admin Wrote: Apple //gs using built-in modem port

Cut the traces and add the solder bridges as shown in the manual - NOTE: NOT AN OPTION!

I use the WiModem232 without having cut the traces, but this states that cutting isn't optional.
Reply
#4
That is correct. It is not optional. Without cutting the traces and making the jumpers, DTR/DSR will not work. These are required for flow control on the Apple IIc/Laser 128/Apple IIgs (internal modem port). So, if you don't cut the traces and add the jumpers then you don't have flow control. You also don't have the ability for ProTERM to know when the modem has lost carrier.
Reply
#5
(02-17-2018, 03:47 PM)admin Wrote: Apple //e with Super Serial Card

TBD - but likely the same as the //gs.

Hi Everyone,

Just a FYI, I followed the Apple //gs settings on my Enhanced Apple //e with Super Serial Card and everything worked great.
Previously I had trouble consistently connecting at 9600 Baud and now it's not problem.

Thanks!

Will
Reply
#6
I got a new keyboard encoder chip for my Apple //e today and I was able to confirm that the //gs settings for the Super Serial Card are the same when used with the //e.
Reply
#7
I have WiModem232v2 which I just received.   It is attached to the IIGS serial modem port. I can connect to BBSs but nothing happens. I get the connected display on the OLED. But nothing happens on the ProTerm v3.1 screen. It just sits there. The BBSs don't populate the screen with the logon request. As soon as I hit a key on the keyboard I get the no carrier on the Proterm display. I can connect at 300 and 9600 baud using appropriate drivers. Same results.

What am I doing wrong?
Reply
#8
What cable are you using?  If you can send the WiModem232 commands (which would have to be true if you are actually connecting to a BBS), then the communications is working.  it could be that your cable has RTS/CTS or DTR tied to some odd line.
Reply
#9
(04-13-2018, 12:00 PM)admin Wrote: What cable are you using?  If you can send the WiModem232 commands (which would have to be true if you are actually connecting to a BBS), then the communications is working.  it could be that your cable has RTS/CTS or DTR tied to some odd line.
Here is the cable I'm using. Brand new. 6ft MDIN8M/DB25M Cable for Mac+/Modem - Beige

https://www.monoprice.com/product?c_id=1...1&format=2

I can post pictures illustrating proterm screen activity and OLED statuses.
Reply
#10
Try going into terminal mode (Apple-T) with ProTERM and send AT&F to reset the settings to default.  

Then try:

ATDTGOOGLE.COM:80

You should see a CONNECT message.  Pressing a key now should not disconnect.  Press +++ which should get you into command mode.  Now typing ATH to disconnect.  If this all works then you should have no issues accessing any BBS.
Reply




Users browsing this thread: 2 Guest(s)